2013西安交大ACM热身赛E题

Description

FJ is about to take his N (1 ≤ N ≤ 30000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input
* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line
Output
The least lexicographic string he can make.
Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.
Sample Input
6
A
C
D
B
C
B
Sample Output
ABCBCD
Hint


看了半天才看懂。。表示英语坑爹啊。。
说下思路,先设置两个游标,首尾各一个。首尾不同的情况简单,直接排就行,如果首尾相同,好吧,继续往里面比较,这里可以分一些情况简化时间复杂度,里面第一层不同,直接把小的外面排过去,其实和后面的是同种情况,不过大多数外面相同的都应当是里面不同的,所以分出来简化时间复杂度,然后是里面相同的,这里开始一个循环,递归应该也可以,不断地往里面进行比较,知道比出大小或者比完了。然后根据不同的情况处理,由于对时间复杂度的要求,这种循环要多处理一些,其他的情况每次处理一只就够了。代码如下



#include<stdio.h>
#include<stdlib.h>
int main(){
	int n,s,e,i,j,p,q;
	char o[30000],m[30000];
	scanf("%d",&n);
	fflush(stdin); 
	s=0;
	e=n-1;
	j=0;
	i=0;	
	while(i<n){
		o[i]=getchar();
		if(o[i]!='\n')i++;
	}
	for(i=0;i<n;){
		if(o[s]<o[e]){
			m[i]=o[s];
			s++;
			i++;
		}else if(o[s]>o[e]){
			m[i]=o[e];
			e--;
			i++;
		}else{
			if(s==e){
				m[i]=o[s];
				i++;
			}
			else{
				p=s;
				q=e;
				while(p<q){
					if(o[p]<o[q]){
						m[i]=o[s];
						s++;
						i++;
						break;
					}else if(o[p]>o[q]){
						m[i]=o[e];
						e--;
						i++;
						break;
					}else{
						if(o[s]<o[p]){
							m[i]=o[s];
							s++;
							i++;
							break;
						}else if(o[s]>=o[p]){
							p++;
							q--;
						}
					}
				}
				if(p>q){
						m[i]=o[s];
						s++;
						i++;
				}else if(p==q){
					for(;s<p;){
						m[i]=o[s];
						s++;
						i++;
					}
				}
			}
		}
	}

	for(i=0;i<n;i++){
		printf("%c",m[i]);
		if((i%80)==79)printf("\n");
	}
	printf("\n");
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值