HDU2602 Bone Collector(01背包模板 一维数组)

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14

题意:给出n,W。表示有n个物品,背包容量为W。
接下来一行是每个物品的价值。
下一行对照着是每个物品的体积。

解题思路:直接套用01背包模板。

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int dp[1010][1010];//最多1000个物品,背包容积最大为1000

int main()
{
    int t,n,W,i,j;
    int w[1010],v[1010];
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        scanf("%d%d",&n,&W);
        for(i=0;i<n;i++)
            scanf("%d",&v[i]);//输入价值
        for(i=0;i<n;i++)
            scanf("%d",&w[i]);//输入体积
        //01背包
        for(i=0;i<n;i++)
            for(j=0;j<=W;j++)//注意范围
            {
                if(j<w[i]) dp[i+1][j]=dp[i][j];
                else dp[i+1][j]=max(dp[i][j],dp[i][j-w[i]]+v[i]);
            }
        printf("%d\n",dp[n][W]);//递推至n,W。得出结果
    }
    return 0;
}

现补上一维数组解法!节省空间(大大滴…)

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int dp[1010];

int main()
{
    int t,n,W,i,j;
    int w[1010],v[1010];
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        scanf("%d%d",&n,&W);
        for(i=0;i<n;i++)
            scanf("%d",&v[i]);
        for(i=0;i<n;i++)
            scanf("%d",&w[i]);

        for(i=0;i<n;i++)
            for(j=W;j>=w[i];j--)
            {
                dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
            }

        printf("%d\n",dp[W]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值