关闭

Ubuntu 下安装Git时遇到的问题 - You might want to run 'apt-get -f install' to correct these

标签: ubuntugit
2910人阅读 评论(0) 收藏 举报
分类:

在Ubuntu下通过apt-get安装Git时,报出的问题:

# apt-get install git
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 curl : Depends: libcurl3-gnutls (= 7.47.0-1ubuntu2) but 7.35.0-1ubuntu2.6 is to be installed
 git : Depends: liberror-perl but it is not going to be installed
       Depends: git-man (> 1:1.9.1) but it is not going to be installed
       Depends: git-man (< 1:1.9.1-.) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
在联网的环境下,按提示执行 apt-get -f install 进行软件修正。

然后再执行安装:

# apt-get install git

1
0
查看评论

ubuntu安装程序时遇到错误 you might want to run 'apt-get -f install' to correct these

问题描述: ubuntu使用”apt-get install“安装程序时遇到错误提示          you might want to run 'apt-get -f install' to correct these ...
  • u012750702
  • u012750702
  • 2016-09-22 22:36
  • 2722

ubuntu图下安装软件出现You might want to run 'apt-get -f install' to correct these解决

今天在ubuntu下安装任何软件都提示以下错误: You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies:  ...
  • qibobo
  • qibobo
  • 2015-03-24 22:40
  • 1660

ubuntu 安装atom

sudo dpkg -i atom-amd64.deb 正在选中未选择的软件包 atom。 (正在读取数据库 ... 系统当前共安装有 178525 个文件和目录。) 正准备解包 atom-amd64.deb  ... 正在解包 atom (1.11.2) .....
  • bfboys
  • bfboys
  • 2016-11-03 18:17
  • 1166

1、Ubuntu下安装软件报错

今天在ubuntu下安装任何软件都提示以下错误: ideallic@ubuntu:~$ sudo apt-get install git [sudo] password for ideallic: Reading package lists... Done Building depende...
  • ideallic
  • ideallic
  • 2016-09-14 14:44
  • 2219

linux下未满足依赖关系错误(1)

刚刚装了新的ubuntu 16.04 安装 curl时出现错误 下列软件包有未满足的依赖关系:  curl : 依赖: libcurl3 (= 7.35.0-1ubuntu2.5) 但是 7.47.0-1ubuntu2 正要被安装 E: 无法修正错误,因为您要求某些软件包保持...
  • yumi94
  • yumi94
  • 2016-04-27 22:05
  • 283

无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系 解决办法

ubuntu下apt-get install安装软件, 报“无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系”,今天终于找到解决方法了。 一般出现这种情况的原因时 要装A, 依赖B, 但是已经安装的软件C也依赖B, 但是A依赖的B的版本和C依赖的B的版本不一致, 导致了如...
  • smallmao
  • smallmao
  • 2015-05-10 22:11
  • 21320

如何解决apt-get中Unmet dependencies问题

新安装的Ubuntu 16.04 TLS系统,由于apt-get upgrade过程中断,导致依赖损坏;安装新的包时,提示Unmet dependencies问题。本文记录了问题的排查方法及解决方案
  • u010096900
  • u010096900
  • 2017-09-30 21:35
  • 683

ubuntu12.04无法安装git的问题

在刚安装的ubuntu下安装git会出现各种问题,通过查找资料,发现网上有两种安装方式,但都遇到了问题,现在就写一下自己的安装过程和遇到的问题 方法一:通过下载git包进行安装 首先是下载git包 # wget http://www.kernel.org/pub/software/sc...
  • huangfukui
  • huangfukui
  • 2017-03-16 20:13
  • 900

在Ubuntu搭建Git

在Ubuntu搭建Git作者:chszs,版权所有,未经同意,不得转载。博主主页:http://blog.csdn.net/chszsGit是一个开源的分布式版本控制系统,它在全球范围内得到广泛的使用。互联网上还有像GitHub这样的网站提供了免费的Git服务,很多流行的开源项目都使用了Git来托管...
  • chszs
  • chszs
  • 2015-09-03 18:50
  • 4404

The following packages have unmet dependencies:

安装编译环境的软件可能会出现的问题 下列软件包有未满足的依赖关系: libasound2: 破坏: libasound2-plugins (< 1.0.24-0ubuntu3) 但是 1.0.22-0ubuntu6 正要被安装 libglib2.0-0: 破坏: gnome-cont...
  • yusiguyuan
  • yusiguyuan
  • 2014-03-17 16:42
  • 9063
    个人资料
    • 访问:208387次
    • 积分:3299
    • 等级:
    • 排名:第12198名
    • 原创:123篇
    • 转载:15篇
    • 译文:11篇
    • 评论:27条
    文章分类
    最新评论