三个QQ的安装

转载 2006年05月28日 14:49:00
最近装好FC4,多媒体也搞好,于是想起QQ。我一下子装了3个版本,以下是我参考网上的方法安装成功的过程,加上我的安装时的改善方法和使用对比结果,希望对大家是个很好的参考。(转贴别忘了写上来源)
一、lumaQQ
http://lumaqq.linuxsir.org/main/
LumaQQ 2004T 初始安装包
带JRE
http://zhy2fly.lysafe.com/web/downlo...ith_jre.tar.gz
http://lumaqq.linuxsir.org/download/...ith_jre.tar.gz
不带JRE
http://zhy2fly.lysafe.com/web/downlo..._no_jre.tar.gz
http://lumaqq.linuxsir.org/download/..._no_jre.tar.gz
http://sdlc-esd.sun.com/ESD14/JSCDL/...x-i586-rpm.bin
LumaQQ 2004T Patch
2005-07-31 19:30(最新)
http://lumaqq.linuxsir.org/download/...7.31.19.30.zip
1)不带JRE版本的LumaQQ安装方法
这个版本没有带JRE,其安装包都用no_jre结尾。安装这个版本需要先安装JRE。我们以lumaqq_2004-linux_gtk_x86_no_jre.tar.gz为例

1. 首先下载JRE 1.4以上版本,这个随便在网上搜搜就能搜出来。在Windows下面,就是一个exe文件,双击一路下去就是。在linux下面,有
rpm的,也有可执行文件形式的,rpm的用 rpm -ivh rpm包名 安装,可执行文件形式的直接运行就开始安装了。

2. 安装JRE,安装完后你有两个选择,这两个选择都是没问题的:
(第一个选择) 什么也不做,脚本将会在/usr目录,/opt目录和你的用户主目录下面搜索JRE。
只要你把JRE装在以上某个目录的下面,程序将会找到JRE,但是,这个找寻JRE的过程可能会狂读你的硬盘,因此我不推荐你这样,
尽量用第二个选择

(第二个选择) 修改/etc/profile或者用户目录的配置文件(比如.bashrc),设置JAVA_HOME环境变量,例如:
JAVA_HOME=/usr/j2sdk1.4.2_01 (把这个替换成你的JRE目录)
export JAVA_HOME
然后使设置生效:你可以注销再登录,也可以直接运行一下/etc/profile
这个方法直接一些,程序不会再去搜索JRE

3. 在JRE或者JDK安装完成后,把安装包拷贝到某个目录,假设是/usr/local,然后用下列命令解压:
tar zxvf lumaqq_2004-linux_gtk2_no_jre.tar.gz
这时/usr/local下会出现LumaQQ目录,你要是不喜欢这个目录,随便你改名移动都行。然后直接运行lumaqq脚本就行啦!

不过呢,要注意两点:
i. lumaqq的脚本使用的是bash shell语法,如果你的环境有所差异,请修改相应的命令
ii. 如果出现权限问题,使用chmod -R 777 [安装目录]更改权限


2)带JRE版本的 LumaQQ 安装方法
这个版本带有JRE,其文件后缀名都是with_jre。安装这个版本更加简单。

1. 以lumaqq_2004-linux_gtk_x86_with_jre.tar.gz为例,将其拷贝到某个目录,假设是/usr/local

2. 执行命令tar zxvf lumaqq_2004-linux_gtk_x86_with_jre.tar.gz解压,这样会在/usr/local下生成一个目录LumaQQ,如果你不喜欢这个目录,随便你把LumaQQ拷贝到哪里都行,随便你重命名成什么都行。

3. 直接运行lumaqq脚本就可以了。不过呢,要注意两点:
i. lumaqq的脚本使用的是bash shell语法,如果你的环境有所差异,请修改相应的命令
ii. 如果出现权限问题,使用chmod -R 777 [安装目录]更改权限

旧版本的 LumaQQ 使用升级补丁
Patch不是完整的程序包,只是升级补丁,所以你需要先安装主程序才能安装Patch,切记。

1. 假设你要升级到最新的Patch,下载了Patch文件后,用unzip [patch文件名]解压

2. 把解压出来的所有jar文件拷贝到LumaQQ的lib目录下,覆盖原来的文件。这样升级就完成了,简单吧。(如果你的系统是Mac OS X,那么这个lib目录是在"LumaQQ安装目录/LumaQQ.app/Contents/Resources/lib")

如果出现权限问题或者NoClassDefFoundException,使用chmod -R 777 [安装目录]更改权限
3)我的安装方法:
我是下载带JRE版本的 LumaQQ ,解压到/root下,把运行脚本图标作个连接,放到桌面就可以使用。

二、gaim+openQQ
最新OpenQ 0.3.2
http://openq.linuxsir.org/
http://openq.linuxsir.org/download/openq-0.3.2.tar.gz
http://sourceforge.net/project/showf...ease_id=272545


(1)官方安装方法参考:

1. tar xjvf OpenQ-latest.tbz
2. cd qq-0.2.7.1
* 安装OpenQ 主程序
3. cd gaim-0.77
4. ./configure --prefix=/opt/OpenQ ( 根据安装情况设定)
5. make
6. sudo make install
* 安装QQ 笑脸
7. mkdir –p $HOME/.gaim/smileys
8. cp –r qq2003iii $HOME/.gaim/smileys
* 安装QQ 秀
9. cp –r qqshow $HOME/.gaim
* 安装IP 地址文件,( 可以安装到任何目录,但一定要在”首选项”中设置)
10. cp QQWry-20040330.dat $HOME/.gaim/
文件权限设置(可选)

11. chown –R $USER $HOME/.gaim
12. chmod –R u+rw $HOME/.gaim

现在安装已经完毕,你可以启动OpenQ, 然后进行设置。
升级用户须知

如果你是OpenQ 0.25 版或更早的用户,请特别注意。由于OpenQ 0.2.7 以后版本中 采用了新的对应关系来解决QQ 号和ICQ 号码的冲突,在升级使用0.2.7 版本或更高的 版本时,必须删除以前的账号然后重新添加QQ 账号,否则会出现混乱。 以前的聊天纪录不会丢失, 不过需要修改一下才行。 比如你的QQ 号是666666, 升级后你要恢复好友777777的聊天纪录。步骤如下:

1. cd $HOME/.gaim/log/666666
2. mv 7777777 qq-7777777
OpenQ 0.2.7 版或更新的用户不用改动。
今后如何升级

我们会在Gaim 发布新的版本(比如0.78) 的时候,尽早发布OpenQ 的更新. 随发布包的有2004 年3 月30 号的IP 地址文件,其实就是大家经常见到的QQwry.dat 文件,根据网上的消息,这个数据包每5 天更新一次,大家可以自行下载最新的IP数据 文件,然后在”首选项”中指定新的文件就可以了。



(2)FC4下安装方法参考:

由于已经安装了gaim0.76的rpm,故不用再编译openq中的gaim部分,只用编译libqq就可以了.

下载gaim0.76
http://ftp.freshrpms.net/pub/freshrp...c1.fr.i386.rpm
安装rpm包
# rpm -Uvh gaim-0.76-1.1.fc1.fr.i386.rpm

下载openq
http://openq.linuxsir.org/download/g...0.2.7.1-p1.tbz
解开openq
$ tar xjvf gaim-qq-latest.tbz

编译libqq
$ cd qq-0.2.7.1-p1/gaim-cvs-0319
$ ./autogen.sh --prefix=/usr
$ cd src/protocols/qq
$ make

安装libqq
# cp qq-0.2.7.1-p1/gaim-cvs-0319/src/protocols/qq/.libs/libqq.so /usr/lib/gaim/libqq.so
# cp qq-0.2.7.1-p1/gaim-cvs-0319/src/protocols/qq/libqq.la /usr/lib/gaim/libqq.la
# cp -f qq-0.2.7.1-p1/gaim-cvs-0319/pixmaps/status/default/*.png /usr/share/pixmaps/gaim/status/default
$ mkdir -p $HOME/.gaim/smileys
$ cp -r qq-0.2.7.1-p1/qq2003iii $HOME/.gaim/smileys
$ cp -r qq-0.2.7.1-p1/qqshow $HOME/.gaim
$ cp QQ-IP-20040305.dat $HOME/.gaim/

3)我自己的方法:
1)注意gaim现在是1.4版,而且新版openqq 没有qqshow,gaim里也有smileys目录。FC4安装gaim是
#yum install gaim
2)我安装openq是使用
#./configure --prefix=/opt/OpenQ
#cp QQ-IP-20050320.dat $HOME/.gaim/
然后把/opt/OpenQ对应的文件拷贝到/usr/lib/gaim里就可以。

三、Eva
http://sourceforge.net/projects/evaq
http://www.magiclinux.org/people/yun...-0.3.0.tar.bz2
1.进入eva目录,输入
./configure --prefix=`kde-config --prefix`
2.成功后,输入
make
开始编译,这大概要7,8分钟的样子,取决于机器的性能
3.输入make install 将安装
Eva到KDE系统中

4.打开命令行,输入
eva
即可运行
注意: 如果您使用过以前版本的eva,请 rm -rf ~/.eva 然后运行eva,如果你希望保留聊天记录,请先将您~/.eva 的 QQ号目录下的chat.msg 复制出来,然后删除.eva目录, 在登录一次后,将chat.msg 复制回去既可。

四、使用对比的结果
1、界面上:lumaQQ比较亲和直观;openq是gaim的界面,比较朴实;Eva类似QQ2005b1的界面,但美工有点别扭。
2、功能上:都有个人聊天、显IP、群聊的功能;但lumaQQ不能文件传输和删除群成员,openq能文件传输和不能删除群成员,Eva基本使用QQ2005b1;3个软件的缺点是没有群共享。
3、操作上:lumaQQ和Eva与真实QQ类似,openq则是gaim的模式。
4、速度上:Eva启动最慢,openq一般而且有时不能登陆,lumaQQ最快。
5、资源上:openq占用较少,Eva和lumaQQ占用较大。
6、其他上:openq弹出的对话框占满桌面,Eva字体不好看,还有...

相关文章推荐

三个QQ号码申请器

  • 2013年01月25日 19:08
  • 1.3MB
  • 下载

Android仿QQ邮箱下拉刷新动画(三个小球围绕中心转动)

仿QQ邮箱下拉刷新动画(三个小球围绕中心转动) 该动画的实现主要借鉴了海龙的博客- 两个小球不停的绕中心旋转的进度条 ,在此感谢下。 1 首先上图(折腾了好久才把gif给搞了上去)2 分析2.1 ...

打开三个qq.exe

  • 2008年10月04日 13:52
  • 20KB
  • 下载

Hadoop-2.6.4集群(三个节点)安装(详细图文)

环境:win7安装虚拟机之后,安装centos6.5,并安装好jdk与mysql,然后克隆三台出来。这样我们安装hadoop的一个基本环境就有了,这次我们是一共三个节点,为什么不把这四台都用了呢?是因...

truecrypt_exe+rpm+deb三个安装包

  • 2008年11月27日 16:58
  • 6.89MB
  • 下载

三个版本的VPN 附带安装使用说明

  • 2013年05月31日 11:22
  • 4.77MB
  • 下载

Oracle安装成功后默认三个用户

SYS用户:超级管理员,权限最高,它的角色是DBA。默认密码是change_on_install。具有创建数据库的权限       SYSTEM用户:系统管理员,权限很高,它的角色是DBA oper...

Cognos C10 Linux安装时 缺失的三个包

  • 2012年10月23日 10:52
  • 1.58MB
  • 下载
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:三个QQ的安装
举报原因:
原因补充:

(最多只允许输入30个字)