hdu 1232 畅通工程(简单并查集)

21 篇文章 0 订阅
1 篇文章 0 订阅

畅通工程

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?

Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。

Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。

Sample Input
4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0

Sample Output
1
0
2
998

Hint
Huge input, scanf is recommended.

水题,太久不做题导致变傻系列。

并查集很久没做了(打acm这么久还不会并查集我也是可以的),虽然能看懂但是蜜汁细节出错。这次这个错我都不想说什么了。

复习一下并查集比较重要的地方,多用在判断图的联通和kruskal算法中。

两个重要的函数(其实就是全部了……)

Find函数:

int find(int x)//递归形式
{
    return f[x] == x ? x : find(f[x]);
}

int find(int x)//非递归形式
{
    while(f[x] != x)
        x = f[x];
    return x;
}

int find(int x)//递归形式
{
    return f[x] == x ? x : f[x] = find(f[x]);//路径压缩优化,可将复杂度降低到近似常数级别
}

并函数(join):

void join(int x, int y)
{
    int fx = find(x), fy = find(y);
    if(fx != fy)//将两个点建立关系。
        f[fy] = fx;
}

ac码——未路径压缩:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <stack>
#define INF 0x3f3f3f3f
#define MAX 1000005
#define M 1005
#define mod 1000000007
#define LL long long

using namespace std;

int f[M];

void init(int n)//初始化
{
    for(int i = 1; i <= n; i++)
    {
        f[i] = i;
    }
}

int _find(int x)//find函数
{
    return f[x] == x ? x : _find(f[x]);
}

void join(int x, int y)//并函数
{
    int fx = _find(x), fy = _find(y);
    if(fx != fy)
        f[fy] = fx;
}

int main()
{
    int n, m;
    while(~scanf("%d", &n) && n)
    {
        scanf("%d", &m);
        init(n);
        for(int i = 0; i < m; i++)
        {
            int t1, t2;
            scanf("%d %d", &t1, &t2);
            join(t1, t2);
        }

        int cnt = 0;
        for(int i = 1; i <= n; i++)//计算有几条通路
        {
            if(f[i] == i)
                cnt++;
        }
        printf("%d\n", cnt - 1);
    }
    return 0;
}

运行结果:
这里写图片描述

ac码——路径压缩(看了kuangbin大神):

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <stack>
#define INF 0x3f3f3f3f
#define MAX 1000005
#define M 1005
#define mod 1000000007
#define LL long long

using namespace std;

int f[M];

void init(int n)
{
    for(int i = 1; i <= n; i++)
    {
        f[i] = -1;//有变化
    }
}

int _find(int x)
{
    if(f[x] == -1)
        return x;
    return f[x] = _find(f[x]);//经过优化
}

void join(int x, int y)
{
    int fx = _find(x), fy = _find(y);
    if(fx != fy)
        f[fy] = fx;
}

int main()
{
    int n, m;
    while(~scanf("%d", &n) && n)
    {
        scanf("%d", &m);
        init(n);
        for(int i = 0; i < m; i++)
        {
            int t1, t2;
            scanf("%d %d", &t1, &t2);
            join(t1, t2);
        }

        int cnt = 0;
        for(int i = 1; i <= n; i++)
        {
            if(f[i] == -1)//有变化
            {
                cnt++;
            }
        }
        printf("%d\n", cnt - 1);
    }
    return 0;
}

运行结果:
这里写图片描述

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值