poj 3621 Sightseeing Cows(最优比率环)

Sightseeing Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7378 Accepted: 2461

Description

Farmer John has decided to reward his cows for their hard work by taking them on a tour of the big city! The cows must decide how best to spend their free time.

Fortunately, they have a detailed city map showing the L (2 ≤ L ≤ 1000) major landmarks (conveniently numbered 1.. L) and the P (2 ≤ P ≤ 5000) unidirectional cow paths that join them. Farmer John will drive the cows to a starting landmark of their choice, from which they will walk along the cow paths to a series of other landmarks, ending back at their starting landmark where Farmer John will pick them up and take them back to the farm. Because space in the city is at a premium, the cow paths are very narrow and so travel along each cow path is only allowed in one fixed direction.

While the cows may spend as much time as they like in the city, they do tend to get bored easily. Visiting each new landmark is fun, but walking between them takes time. The cows know the exact fun values Fi (1 ≤ Fi ≤ 1000) for each landmark i.

The cows also know about the cowpaths. Cowpath i connects landmark L1i to L2i (in the direction L1i -> L2i ) and requires time Ti (1 ≤ Ti ≤ 1000) to traverse.

In order to have the best possible day off, the cows want to maximize the average fun value per unit time of their trip. Of course, the landmarks are only fun the first time they are visited; the cows may pass through the landmark more than once, but they do not perceive its fun value again. Furthermore, Farmer John is making the cows visit at least two landmarks, so that they get some exercise during their day off.

Help the cows find the maximum fun value per unit time that they can achieve.

Input

* Line 1: Two space-separated integers: L and P
* Lines 2..L+1: Line i+1 contains a single one integer: Fi
* Lines L+2..L+P+1: Line L+i+1 describes cow path i with three space-separated integers: L1i , L2i , and Ti

Output

* Line 1: A single number given to two decimal places (do not perform explicit rounding), the maximum possible average fun per unit time, or 0 if the cows cannot plan any trip at all in accordance with the above rules.

Sample Input

5 7
30
10
10
5
10
1 2 3
2 3 2
3 4 5
3 5 2
4 5 5
5 1 3
5 2 2

Sample Output

6.00
 
题意:给出一个有向图,每个结点都有一个权值,要求出一个环,这个环的点的(权值之和:总的长度)要最大。
思路:类似求最优比率生成树的方法,用01分数规划。这里用spfa求最长路,判是否存在正环。
 
AC代码:
#include <iostream>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <queue>
#include <ctime>
#include <vector>
#include <algorithm>
#define ll long long
#define L(rt) (rt<<1)
#define R(rt)  (rt<<1|1)
#define eps 1e-6
using namespace std;

const double INF = 1e9 + 7;
const int maxn = 1005;

struct Edge{
    int v;
    double w;
    int next;
}et[maxn * maxn];
int eh[maxn], cnt[maxn];
double dis[maxn], val[maxn];
bool vis[maxn];
int n, m, num;
void init(){
    memset(eh, -1, sizeof(eh));
    num = 0;
}
void add(int u, int v, double w){
    Edge e = {v, w, eh[u]};
    et[num] = e;
    eh[u] = num++;
}
bool spfa(double mid){
    queue<int> Q;
    for(int i = 1; i <= n; i++)
    {
        dis[i] = 0;
        cnt[i] = 1;
        vis[i] = true;
        Q.push(i);
    }
    while(!Q.empty())
    {
        int u = Q.front();
        Q.pop();
        vis[u] = false;
        for(int i = eh[u]; i != -1; i = et[i].next)
        {
            int v = et[i].v;
            double w = val[u] - mid * et[i].w;
            if(dis[v] < dis[u] + w)
            {
                dis[v] = dis[u] + w;
                if(!vis[v])
                {
                    if(++cnt[v] > n) return true;
                    vis[v] = true;
                    Q.push(v);
                }
            }
        }
    }
    return false;
}
int main()
{
    int a, b;
    double c;
    while(~scanf("%d%d", &n, &m))
    {
        init();
        for(int i = 1; i <= n; i++)
        scanf("%lf", &val[i]);
        while(m--)
        {
            scanf("%d%d%lf", &a, &b, &c);
            add(a, b, c);
        }
        double low = 0, high = 1000;
        while(high - low > eps)
        {
            double mid = (low + high) / 2;
            if(spfa(mid)) low = mid;
            else high = mid;
        }
        printf("%.2f\n", low);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值