hdu 4405 Aeroplane chess(概率dp)

3 篇文章 0 订阅

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1212    Accepted Submission(s): 825


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases.
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0.
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
  
  
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
  
  
1.1667 2.3441
 
 
题意:有一个飞行棋棋盘,起点在0点,每次投掷一次骰子,之后走骰子上显示的步数。一些点设有航线,走到这些点时就会飞到指定的地方。给出棋盘的长度以及航线,求到达点n的需要投掷骰子的期望次数。
思路:概率dp入门题,设dp[i]为到点i时的期望次数,显然dp[n]=0,最终结果是dp[0]。
易得转移方程dp[i]=dp[i+1]*(1/6)+dp[i+2]*(1/6)+dp[i+3]*(1/6)+dp[i+4]*(1/6)+dp[i+5]*(1/6)+dp[i+6]*(1/6)+1,
而对于航线xi到yi,dp[xi]=dp[yi]
 
AC代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <cmath>
#include <algorithm>
#define ll long long

using namespace std;

const int INF = 1e9;
const int maxn = 100010;
const int mod = 100000000;

vector<int> G[maxn];
int n, m;
bool vis[maxn];
double dp[maxn];
int main()
{
    int a, b;
    while(scanf("%d%d", &n, &m), n || m)
    {
        for(int i = 1; i <= n; i++) G[i].clear();
        memset(vis, false, sizeof(vis));
        memset(dp, 0, sizeof(dp));
        dp[n] = 0;
        while(m--)
        {
            scanf("%d%d", &a, &b);
            G[b].push_back(a);
        }
        for(int i = 0; i < (int)G[n].size(); i++)
        {
            int v = G[n][i];
            dp[v] = 0;
            vis[v] = true;
        }
        for(int i = n - 1; i >= 0; i--)
        {
            if(!vis[i])
            {
                for(int j = i + 1; j <= i + 6; j++)
                dp[i] += dp[j] / 6;
                dp[i] += 1;
            }
            for(int j = 0; j < (int)G[i].size(); j++)
            {
                int v = G[i][j];
                dp[v] = dp[i];
                vis[v] = true;
            }
        }
        printf("%.4f\n", dp[0]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值