hdu 1724 Ellipse(Simpson积分法)

17 篇文章 0 订阅

Ellipse

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1152    Accepted Submission(s): 435


Problem Description
Math is important!! Many students failed in 2+2’s mathematical test, so let's AC this problem to mourn for our lost youth..
Look this sample picture:
 
 


A ellipses in the plane and center in point O. the L,R lines will be vertical through the X-axis. The problem is calculating the blue intersection area. But calculating the intersection area is dull, so I have turn to you, a talent of programmer. Your task is tell me the result of calculations.(defined PI=3.14159265 , The area of an ellipse A=PI*a*b )
 

Input
Input may contain multiple test cases. The first line is a positive integer N, denoting the number of test cases below. One case One line. The line will consist of a pair of integers a and b, denoting the ellipse equation , A pair of integers l and r, mean the L is (l, 0) and R is (r, 0). (-a <= l <= r <= a).
 

Output
For each case, output one line containing a float, the area of the intersection, accurate to three decimals after the decimal point.
 

Sample Input
  
  
2 2 1 -2 2 2 1 0 2
 

Sample Output
  
  
6.283 3.142
 
 
 
 
 
AC代码:
#include <iostream>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <queue>
#include <ctime>
#include <algorithm>
#define ll long long

using namespace std;

const int INF = 1e9;
const int maxn = 505;
const double eps = 1e-8;

double a, b;
double F(double x){
    return 2.0 * b * sqrt(1.0 - x * x / (a * a));
}
double simpson(double l, double r){
    double mid = (l + r) / 2.0;
    return (r - l) * (F(l) + 4.0 * F(mid) + F(r)) / 6.0;
}
double work(double l, double r, double sum){
    double mid = (l + r) / 2.0;
    double ls = simpson(l, mid);
    double rs = simpson(mid, r);
    if(abs(ls + rs - sum) <= eps) return sum;
    return work(l, mid, ls) + work(mid, r, rs);
}
int main()
{
    int t;
    double l, r;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%lf%lf%lf%lf", &a, &b, &l, &r);
        double ans = work(l, r, simpson(l, r));
        printf("%.3f\n", ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值