poj 1635 Subway tree systems

16 篇文章 0 订阅
Subway tree systems
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6203 Accepted: 2580

Description

Some major cities have subway systems in the form of a tree, i.e. between any pair of stations, there is one and only one way of going by subway. Moreover, most of these cities have a unique central station. Imagine you are a tourist in one of these cities and you want to explore all of the subway system. You start at the central station and pick a subway line at random and jump aboard the subway car. Every time you arrive at a station, you pick one of the subway lines you have not yet travelled on. If there is none left to explore at your current station, you take the subway line back on which you first came to the station, until you eventually have travelled along all of the lines twice,once for each direction. At that point you are back at the central station. Afterwards, all you remember of the order of your exploration is whether you went further away from the central station or back towards it at any given time, i.e. you could encode your tour as a binary string, where 0 encodes taking a subway line getting you one station further away from the central station, and 1 encodes getting you one station closer to the central station.

Input

On the first line of input is a single positive integer n, telling the number of test scenarios to follow.Each test scenario consists of two lines, each containing a string of the characters '0' and '1' of length at most 3000, both describing a correct exploration tour of a subway tree system.

Output

exploration tours of the same subway tree system, or the text "different" if the two strings cannot be exploration tours of the same subway tree system.

Sample Input

2
0010011101001011
0100011011001011
0100101100100111
0011000111010101

Sample Output

same
different
 
题意:给定两棵树,用一串0或1的序列表示,0表示生成一个子节点,1表示返回父节点。判断这样的两棵树是否同构。
用树的最小表示求解,将每个子树按字典序排序,最后得到的树如果完全相同,即为同构
 
AC代码:
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>

using namespace std;
string ss,a,b;
string get_tree(int i)
{
    vector<string>v;
    int n=ss.size();
    while(i<n&&ss[i]=='0')
    {
        v.push_back('0'+get_tree(i+1));
        i+=v.back().size();
    }
    string r;
    sort(v.begin(),v.end());
    for(int i=0;i<(int)v.size();i++)
    r+=v[i];
    return r+'1';
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>ss;
        a=get_tree(0);
        cin>>ss;
        b=get_tree(0);
        cout<<(a==b?"same":"different")<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值