poj 1364 King

King
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8792 Accepted: 3311

Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.'' After nine months her child was born, and indeed, she gave birth to a nice son.
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence.

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son's skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions.

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong.

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions.

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not.

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king's decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy
 
题意:给出若干个关系si,ni,oi,ki,若oi=gt,则表示(si+ni)-(si-1)>ki;若oi=lt,则表示(si+ni)-(si-1)<ki。问关系中是否存在矛盾。
思路:对于关系(si+ni)-(si-1)>ki,可以化为(si+ni)-(si-1)>=ki+1,对于关系(si+ni)-(si-1)<ki,可以化为(si+ni)-(si-1)<=ki-1.然后建立相应的边即可。注意存在图不连通的情况,要设一个超级源点n+1.
 
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <map>


using namespace std;

const int INF=100000000;
const int maxn=105;

struct node
{
    int v,w,next;
} edge[205];
int head[maxn],dis[maxn],cnt[maxn];
bool vis[maxn];
int num,n,m;
void init()
{
    for(int i=0; i<=n+1; i++)
        head[i]=-1;
    num=0;
}
void add(int u,int v,int w)
{
    edge[num].v=v;
    edge[num].w=w;
    edge[num].next=head[u];
    head[u]=num++;
}
void spfa()
{
    queue<int>Q;
    for(int i=0; i<=n+1; i++)
        dis[i]=INF;
    dis[n+1]=0;
    memset(vis,false,sizeof(vis));
    memset(cnt,0,sizeof(cnt));
    vis[n+1]=true;
    Q.push(n+1);
    cnt[n+1]++;
    while(!Q.empty())
    {
        int x=Q.front();
        Q.pop();
        vis[x]=false;
        for(int i=head[x]; i!=-1; i=edge[i].next)
        {
            if(dis[edge[i].v]>dis[x]+edge[i].w)
            {
                dis[edge[i].v]=dis[x]+edge[i].w;
                if(!vis[edge[i].v])
                {
                    vis[edge[i].v]=true;
                    if(++cnt[edge[i].v]>n+2)
                    {
                        printf("successful conspiracy\n");
                        return;
                    }
                    Q.push(edge[i].v);
                }
            }
        }
    }
    printf("lamentable kingdom\n");
}
int main()
{
    int si,ni,ki;
    char oi[5];
    while(scanf("%d",&n),n)
    {
        scanf("%d",&m);
        init();
        while(m--)
        {
            scanf("%d%d%s%d",&si,&ni,oi,&ki);
            if(oi[0]=='g')
                add(si+ni,si-1,-ki-1);
            else
                add(si-1,si+ni,ki-1);
        }
        for(int i=0; i<=n; i++)
            add(n+1,i,0);
        spfa();
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值