【POJ 2686 Traveling by Stagecoach】+ 状压dp

47 篇文章 3 订阅
2 篇文章 0 订阅

Traveling by Stagecoach
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3102 Accepted: 1162 Special Judge

Description
Once upon a time, there was a traveler.

He plans to travel using stagecoaches (horse wagons). His starting point and destination are fixed, but he cannot determine his route. Your job in this problem is to write a program which determines the route for him.

There are several cities in the country, and a road network connecting them. If there is a road between two cities, one can travel by a stagecoach from one of them to the other. A coach ticket is needed for a coach ride. The number of horses is specified in each of the tickets. Of course, with more horses, the coach runs faster.

At the starting point, the traveler has a number of coach tickets. By considering these tickets and the information on the road network, you should find the best possible route that takes him to the destination in the shortest time. The usage of coach tickets should be taken into account.

The following conditions are assumed.

A coach ride takes the traveler from one city to another directly connected by a road. In other words, on each arrival to a city, he must change the coach.
Only one ticket can be used for a coach ride between two cities directly connected by a road.
Each ticket can be used only once.
The time needed for a coach ride is the distance between two cities divided by the number of horses.
The time needed for the coach change should be ignored. 

Input
The input consists of multiple datasets, each in the following format. The last dataset is followed by a line containing five zeros (separated by a space).

n m p a b
t1 t2 … tn
x1 y1 z1
x2 y2 z2

xp yp zp

Every input item in a dataset is a non-negative integer. If a line contains two or more input items, they are separated by a space.

n is the number of coach tickets. You can assume that the number of tickets is between 1 and 8. m is the number of cities in the network. You can assume that the number of cities is between 2 and 30. p is the number of roads between cities, which may be zero.

a is the city index of the starting city. b is the city index of the destination city. a is not equal to b. You can assume that all city indices in a dataset (including the above two) are between 1 and m.

The second line of a dataset gives the details of coach tickets. ti is the number of horses specified in the i-th coach ticket (1<=i<=n). You can assume that the number of horses is between 1 and 10.

The following p lines give the details of roads between cities. The i-th road connects two cities with city indices xi and yi, and has a distance zi (1<=i<=p). You can assume that the distance is between 1 and 100.

No two roads connect the same pair of cities. A road never connects a city with itself. Each road can be traveled in both directions.

Output
For each dataset in the input, one line should be output as specified below. An output line should not contain extra characters such as spaces.

If the traveler can reach the destination, the time needed for the best route (a route with the shortest time) should be printed. The answer should not have an error greater than 0.001. You may output any number of digits after the decimal point, provided that the above accuracy condition is satisfied.

If the traveler cannot reach the destination, the string “Impossible” should be printed. One cannot reach the destination either when there are no routes leading to the destination, or when the number of tickets is not sufficient. Note that the first letter of “Impossible” is in uppercase, while the other letters are in lowercase.

Sample Input

3 4 3 1 4
3 1 2
1 2 10
2 3 30
3 4 20
2 4 4 2 1
3 1
2 3 3
1 3 3
4 1 2
4 2 5
2 4 3 4 1
5 5
1 2 10
2 3 10
3 4 10
1 2 0 1 2
1
8 5 10 1 5
2 7 1 8 4 5 6 3
1 2 5
2 3 4
3 4 7
4 5 3
1 3 25
2 4 23
3 5 22
1 4 45
2 5 51
1 5 99
0 0 0 0 0

Sample Output

30.000
3.667
Impossible
Impossible
2.856

Hint
Since the number of digits after the decimal point is not specified, the above result is not the only solution. For example, the following result is also acceptable.

30.0

3.66667

Impossible

Impossible

2.85595

状压dp~姑且把到达该城市时剩余票的集合看成一种状态~依次不断更新到达能该城市的状态的最优解~即可~~

AC代码:(516MS)

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
int T[10],d[32][32];
double dp[1 << 10][30]; // 到达该城市时剩余票的集合的最优解
int main()
{
    int N,M,p,a,b,x,y,z;
    while(scanf("%d %d %d %d %d",&N,&M,&p,&a,&b) != EOF){
       if(N == 0 && M == 0 && p == 0 && a == 0 && b == 0) break;
       --a;--b; //把点统一为 0 ~ M - 1
       for(int i = 0 ; i < N; i++)
            scanf("%d",&T[i]);
        memset(d,-1,sizeof(d));
       while(p--){
        scanf("%d %d %d",&x,&y,&z);
        x--;y--;
        d[x][y] = d[y][x] = z;
       }
       for(int i = 0 ; i < (1 << N) ; i++) // 初始化
        fill(dp[i],dp[i] + M,INF * 1.0);
       dp[(1 << N) - 1][a] = 0.0;
       double ans = INF * 1.0;
       for(int s = (1 << N) - 1; s >= 0 ; s--){
          ans = min(ans,dp[s][b]);
        for(int v = 0 ; v < M ;v++)
            for(int i = 0 ; i < N; i++)
              if(s >> i & 1){ // i元素是否在集合s中
                for(int u = 0 ; u < M ; u++) // 从 v 移动到 u
                    if(d[v][u] >= 0) 
                        dp[s & ~(1 << i)][u] = min(dp[s & ~(1 << i)][u],dp[s][v] + (double)(d[v][u]  * 1.0 / T[i]));
            }
       }
       if(ans == INF) printf("Impossible\n");
       else printf("%.3lf\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值