【POJ 2718 Smallest Difference】+ 排列组合

18 篇文章 0 订阅
7 篇文章 0 订阅

Smallest Difference
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10493 Accepted: 2867
Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0.

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.
Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, …, 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.
Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.
Sample Input

1
0 1 2 4 6 7
Sample Output

28

排列 + 暴力

AC代码:

#include<cstdio>
#include<cmath>
#include<map>
#include<algorithm>
#include<iostream>
using namespace std;
int a[12],pl;
void solve(){
    while(a[0] == 0) next_permutation(a,a + pl); // 首位不能为零
    int ans = 99999999;
    int mid = pl / 2;
    do{
        if(a[mid]){ // 首位不能为零
            int ma = a[0],mb = a[mid];
            for(int i = 1; i < mid; i++)
                ma = ma * 10 + a[i];
            for(int i = mid + 1;i < pl; i++)
                mb = mb * 10 + a[i];
            if(ans > abs(ma - mb))
                ans = abs(ma-mb);
        }
      }while(next_permutation(a,a + pl));
    cout<< ans <<endl;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){

        char s;
        int N;
        pl = 0;
        while(scanf("%d%c",&N,&s) != EOF){
            a[pl++] = N;
            if(s == '\n') break;
        }
        if(pl == 1) printf("%d\n",a[0]);
        else if(pl == 2) printf("%d\n",abs(a[0] - a[1]));
        else solve();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值