【POJ 2192 Zipper】+ 贪心 + 字符匹配

34 篇文章 0 订阅
14 篇文章 0 订阅

Zipper
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18323 Accepted: 6523
Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming “tcraete” from “cat” and “tree”:

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming “catrtee” from “cat” and “tree”:

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form “cttaree” from “cat” and “tree”.
Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.
Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree
Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

每次尽可能的让 s 最后面的字符与 s1 || s2 最后的字符匹配,若相同者继续比较前一个

AC代码:

#include<cstdio>
#include<cstring>
#include<map>
#include<string>
#include<iostream>
using namespace std;
const int K = 210;
string s1,s2,s;
bool pd(int n,int n1,int n2){
    while(n1 >= 0 && n2 >= 0 && s[n] == s1[n1] && s[n] == s2[n2]) n--,n1--,n2--;
    if(n1 < 0) return 0;
    if(n2 < 0) return 1;
    if(s[n] == s1[n1] && s[n] != s2[n2]) return 1;
    if(s[n] == s2[n2] && s[n] != s1[n1]) return 0;
}
int main()
{
    int N,nl = 0;
    scanf("%d",&N);
    while(N--){
        cin >> s1 >> s2 >> s;
        int n1 = s1.size() - 1;
        int n2 = s2.size() - 1;
        int n = s.size() - 1;
        int ok = 1;
        while(ok && (n1 >= 0 || n2 >= 0 || n >= 0)){
           if(n < 0) break;
           if(n1 >= 0 && s[n] == s1[n1] && s[n] != s2[n2]) n--,n1--;
           else if(n2 >= 0 && s[n] == s2[n2] && s[n] != s1[n1]) n--,n2--;
           else if(n1 >= 0 && n2 >= 0 && s[n] == s1[n1] && s[n] == s2[n2])
                 if(pd(n,n1,n2)) n--,n1--;
                 else n--,n2--;
          else ok = 0;
       }
       if(n1 >= 0 || n2 >= 0) ok = 0;
       printf("Data set %d: ",++nl);
       if(ok) printf("yes\n");
       else printf("no\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值