【Lightoj 1063 - Ant Hills】& 割点

After many years of peace, an ant-war has broken out.

In the days leading up to the outbreak of war, the ant government devoted a great deal of resources toward gathering intelligence on ant hills. It discovered the following:

  1. The ant empire has a large network of ant-hills connected by bidirectional tracks.
  2. It is possible to send a message from any ant hill to any other ant hill.

Now you want to stop the war. Since they sometimes attack your house and disturb you quite a lot. So, you have made a plan. You have a gun which can destroy exactly one ant-hill. So, you want to hit an ant hill if it can stop at least two other ant hills passing messages between them. Now you want the total number of ant hills you may choose to fire.

Input
Input starts with an integer T (≤ 20), denoting the number of test cases.

Each test case contains a blank line and two integers n (1 ≤ n ≤ 10000), m (1 ≤ m ≤ 20000). n denotes the number of ant hills and m denotes the number of bi-directional tracks. Each of the next m lines will contain two different integers a b (1 ≤ a, b ≤ n) denoting that there is a track between a and b.

Output
For each case, print the case number and the total number of ant hills you may choose to fire.

Sample Input
2

5 4
2 1
1 3
5 4
4 1

3 3
1 2
2 3
1 3
Sample Output
Case 1: 2
Case 2: 0

题意 : 去掉 一个点 a 可以让至少两个以上的点不在联通,求这样的点有多少个

思路 : 割点 (图论基础题?我之前学了假图论?QAQ)

AC代码:

#include<bits/stdc++.h>
using namespace std;
const int MAX = 1e5 + 10;
const int INF = 1e9 + 7;
typedef long long LL;
int n,m,nl,head[MAX * 4];
int lo[MAX],d[MAX],pl,p[MAX];
struct node{
    int to,next;
}st[MAX * 4];
void init(){
    nl = 0;
    pl = 1;
    memset(head,-1,sizeof head);
    memset(d,0,sizeof d);
    memset(lo,0,sizeof lo);
    memset(p,0,sizeof p);
}
void add(int x,int y){
    st[nl] = node{y,head[x]};
    head[x] = nl++;
}
void Tarjan(int u,int f){
    lo[u] = d[u] = pl++;
    int son = 0;
    for(int i = head[u]; i != -1; i = st[i].next){
        int v = st[i].to;
        if(v == f) continue;
        if(!d[v]){
            Tarjan(v,u);
            lo[u] = min(lo[u],lo[v]);
            if(f == -1 && son) p[u] = 1;
            if(f != -1 && lo[v] >= d[u]) p[u] = 1;
            son++;
        }
        else
            lo[u] = min(lo[u],d[v]);
    }
}
void input(){
    int x,y;
    scanf("%d %d",&n,&m);
    while(m--){
        scanf("%d %d",&x,&y);
        add(x,y);
        add(y,x);
    }
}
void solve(){
    for(int i = 1; i <= n; i++)
        if(!d[i])
            Tarjan(i,-1);
}
int main()
{
    int T,cas = 0;
    scanf("%d",&T);
    while(T--){
        init();
        input();
        solve();
        int ll = 0;
        for(int i = 1; i <= n; i++)
            if(p[i])
                ll++;
        printf("Case %d: %d\n",++cas,ll);
    }
    return 0;
}
深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值