POJ 1083 Moving Tables

 The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30
 
  
解题思路:最初想法是按照每个区间左端点从小到大的顺序排序,然后任意两个不相邻的区间之间连一条有向边例如第i个区间和第j个区间(j>i)之间不相交,则i向j连一条边,这样构图的话,我们最终会得到一个DAG,其实我们这道题的答案便是在某一段区间内被占用的那个最多的次数即为最多需要多少次搬运,这样我们在DAG中利用拓扑排序,记录一下每一时刻队列或栈中的节点的个数,此时队列中的任意两点之间是不存在边的,即队列中任意两个点代表的区间是相交的,这样我们取最大值便是我们需要多少趟搬运,这样在房间号很大,但N很小的时候我们便可以利用此方法解决。当然本题中房间号最大为400,我们完全可以用一个计数器记录每个房间被占用的次数,然后取最大值,即为我们要求的结果,当然对房间号很大时,我们可以对区间离散化处理后,同样可以在O(N)的时间内解决。
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <utility>
#include <algorithm>
#include <functional>
using namespace std;
const int maxn = 410;
int   cnt[maxn];


int main() {

    //freopen("aa.in", "r", stdin);

    int T, n, a, b;
    scanf("%d", &T);
    while(T--) {
        scanf("%d", &n);
        memset(cnt, 0, sizeof(cnt));
        for(int i = 1; i <= n; ++i) {
            scanf("%d %d", &a, &b);
            if(a > b) swap(a, b);
            if(a%2 == 0) a--;
            if(b%2) b++;
            for(int j = a; j <= b; ++j) {
                cnt[j]++;
            }
        }
        int max_cnt = 0;
        for(int i = 1; i <= 400; ++i) {
            if(cnt[i] > max_cnt) {
                max_cnt = cnt[i];
            }
        }
        printf("%d\n", max_cnt*10);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值