关闭

CocoPods报错:[!] The dependency `XXX` is not used in any concrete target.

460人阅读 评论(0) 收藏 举报
分类:

CocoPods报错:[!] The dependency `XXX` is not used in any concrete target.

一、我的CocoPod未更新,同事的CocoPod已更新为最新版本。

我从svn仓库更新下代码,准备添加一个第三方,我pod search 后添加到Podfile文件中,执行pod install;提示我CocoPod中不能找到最新的 pod 'Mantle', '~> 2.0.7' 例如:2.0.7 这时我试着先删除这个Mantle这个第三方,继续执行pod install,当然还是报错,具体截图暂无保留,意思就是提示我Podfile文件中不能执行Mantle这个第三方。

我决然的删除Podfile.lock文件后重新pod install解决

二、为了CocoPod同步,我计划更新CocoPod库

更新后我删除了所有的版本号(为了所有都使用最新版本),执行pod install,报错类似如下:
     [!] The dependency `XXX` is not used in any concrete target.

原因:这个第三方不知道用于哪个target,所以必须指定target
解决方案:修改Podfile文件中内容如下格式:需将引号中的红色target名换成您自己的target名
target "SailProject" do
pod 'BlocksKit', '
end



0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:101322次
    • 积分:1742
    • 等级:
    • 排名:千里之外
    • 原创:73篇
    • 转载:14篇
    • 译文:0篇
    • 评论:13条
    个人资料
    最新评论