Cocopods

转载 2015年11月19日 17:35:22

一、概要

iOS开发时,项目中会引用许多第三方库,CocoaPods(https://github.com/CocoaPods/CocoaPods)可以用来方便的统一管理这些第三方库。


二、安装

由于网上的教程基本都大同小异,但细节之处还不是很完善,所以借机会在这里补充下:

注:要使用CocoaPods,那就要下载安装它,而下载安装CocoaPods需要Ruby环境


1、Ruby环境搭建

当前安装环境为Mac mini 10.8.5。Mac  OS本身自带Ruby,但还是更新一下保险,因为我第一次安装在没有更新Ruby的情况下就失败了。

a 查看下当前ruby版本:打开终端输入 ruby -v(确实安装了,不过用这个版本接下来工作失败了,所以更新下ruby)

  1. ritekiMac-mini:PodTest lucky$ ruby -v  
  2. ruby 1.8.7 (2012-02-08 patchlevel 358) [universal-darwin12.0]  
  3. ritekiMac-mini:PodTest lucky$   

b 更新ruby

终端输入如下命令(把Ruby镜像指向taobao,避免被墙,你懂得

gem sources --remove https://rubygems.org/ 
gem sources -a https://ruby.taobao.org/ 
gem sources -l  (用来检查使用替换镜像位置成功)

  1. ritekiMac-mini:~ lucky$ gem sources --remove https://rubygems.org/  
  2. https://rubygems.org/ removed from sources  
  3. ritekiMac-mini:~ lucky$ gem sources -a https://ruby.taobao.org/  
  4. https://ruby.taobao.org/ added to sources  
  5. ritekiMac-mini:~ lucky$ gem sources -l  
  6. *** CURRENT SOURCES ***  


2、下载安装CocoaPods

终端输入:sudo gem install cocoapods 


  1. ritekiMac-mini:~ lucky$ sudo gem install cocoapods  
  2.   
  3. CHANGELOG:  
  4.   
  5. ## 0.32.1  
  6.   
  7. ##### Bug Fixes  
  8.   
  9. * Fixed the Podfile `default_subspec` attribute in nested subspecs.    
  10.   [Fabio Pelosin][irrationalfab]  
  11.  \ [#2050](https://github.com/CocoaPods/CocoaPods/issues/2050)  
  12.   
  13.   
  14. Successfully installed cocoapods-0.32.1  
  15. Installing ri documentation for cocoapods-0.32.1  
  16. /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rdoc/rdoc.rb:280: warning: conflicting chdir during another chdir block  
  17. /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rdoc/rdoc.rb:287: warning: conflicting chdir during another chdir block  
  18. Done installing documentation for cocoapods after 10 seconds  
  19. 1 gem installed  


这样就下载安装好了CocoaPods


3、使用CocoaPods

a  新建一个项目,名字PodTest



b  终端中,cd到项目总目录(注意:包含PodTest文件夹、PodTest.xcodeproj、PodTestTest的那个总目录)

  1. cd /Users/lucky/Desktop/PodTest   

c  建立Podfile(配置文件)

接着上一步,终端输入 vim Podfile



键盘输入 i,进入编辑模式,输入

platform :ios, '7.0' 
pod 'MBProgressHUD', '~> 0.8'


然后按Esc,并且输入“ :”号进入vim命令模式,然后在冒号后边输入wq



注意:键盘输入 :后,才能输入wq。回车后发现PodTest项目总目录中多一个Podfile文件



激动人心的时刻到了:确定终端cd到项目总目录,然后输入 pod install,等待一会,大约3分钟。



查看项目根目录:



注意:现在打开项目不是点击 PodTest.xodeproj了,而是点击 PodTest.xcworkspace


打开项目后看到项目结构并且测试一下:



运行结果:



补充:

1、CocoaPods的基本安装及使用都详细的说明了,但还有一些补充,当需要同时导入多个第三方时候怎么办 ?

这就需要修改Podfile了,就是用vim编辑的那个保存在项目根目录中的文件,修改完了Podfile文件,需要重新执行一次pod install命令。

例如:

platform :ios

pod 'JSONKit',       '~> 1.4'

pod 'AFNetworking',  '~> 2.0'


2、CocoaPods可以查找你想要的第三方库

终端输入命令:pod search UI

疯了了,我怎么查找这么大众的关键字,好多库~~


然后重新编辑Podfile文件,按照之前的步骤,把更多的库都导入项目!


本博客盗窃自阿福的博客,地址:http://blog.csdn.net/lizhongfu2013/article/details/26384029


============================我是分割线==================================

2015-11-18更新

淘宝已经关闭HTTP协议的景象服务,改为HTTPS协议。

淘宝ruby地址:https://ruby.taobao.org/

相关文章推荐

cocopods 安装使用指南

cocoapods简介:          cocoapods 是iOS的类库管理工具,可以让开发者很方便集成各种第三方库,而不用去网站上一个个下载,再一个个文件夹的拖进项目中,还得添加相关的系...

Cocopods 安装坑

,1.客户端不好用,环境装坏了,卸掉,客户端资料没多少。 2.全部卸载干净,然后重新安装。 3.卸载参考http://www.meetrue.com/archives/133 4.只跟着做卸载,...

安装并解决最近cocopods不能用的问题

作为一个iOS软件开发工程师,不可能不用到第三方库,用到第三方库,就肯定会用到cocopods,但是最近因为cocopods升级,很多用户都反映cocopods不能使用,都抓狂了吧,最新版本是1.0....

自己安装cocopods过程遇到问题,菜鸟一个不喜勿喷!

个人安装cocoapods 总结

cocopods 安装 最新

一、安装过程1、移除默认源$ gem sources –remove https://rubygems.org/2、添加源(现在不添加这个源了:https://ruby.taobao.org/,貌似不...

iOS Cocopods的安装和导入第三方

1.移除现有Ruby默认源 gem sources --remove https://rubygems.org/ 2.使用新的源 gem sources -a https://ruby.tao...

cocopods问题

1.无论是执行pod install还是pod update都卡在了Analyzing dependencies 或者 Updating local specs repositories不动  解决...

cocopods安装时 Mac os 10.12.1 遇见的问题

Last login: Tue Oct 25 11:51:04 on ttys000 pcdeMacBook-Pro:~ lizongyao$ sudo gem uninstall cocoap...

虚拟机重新安装COCOPODS

进入终端:[注意是HTTPS,有个“S”] $ gem sources -a https://ruby.taobao.org/ $ gem sources --remove https...
  • xocom
  • xocom
  • 2016年04月20日 10:03
  • 197

[绍棠] cocopods卸载、安装、重装等问题解决

最近遇到pods更新出错了问题, 只有删除重新安装了 一、全新安装前,先检查是否有安装残留 1、如果之前装过cocopods,最好先卸载掉,卸载命令: $ sudo gem uninstall ...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Cocopods
举报原因:
原因补充:

(最多只允许输入30个字)