关闭

Ubuntu不能利用ssh进行远程连接的解决方案及其解决过程中出现的问题

595人阅读 评论(0) 收藏 举报
分类:
Ubuntu不能进行远程连接可能因为如下几方面的问题。
解决办法:
(1)查看ip地址是否冲突
我在单位的虚拟机ip地址是192.168.14.85,与其它机器冲突了。改成了192.168.14.83

(2)关闭Ubuntu14.04的防火墙

root@stgman-desktop:~# sudo ufw disable

防火墙在系统启动时自动禁用

自尝试了sudo ufw enable,从我的win7系统ssh登录不上虚拟机。但是在Ubuntu本机上ssh 192.168.14.83可以登录成功。


(3)Ubuntu系统上安装、启动sshd服务

Ubuntu可能没有安装启动openssh-server服务。

用以下命令来查看,如果没有显示sshd则说明没有安装openssh-server

ps -e | grep ssh

用以下命令来安装openssh-server

sudo apt-get install openssh-server

安装完成后重新启动ssh服务即可实现远程ssh连接。重启命令为:

sudo /etc/init.d/ssh restart  -5

在安装过程中可能会出现一些问题,比如说没有依赖项openssh-client等,这是既是你使用

sudo apt-get install openssh-client成功安装上,并显示一是最新的openssh-client.在安装openssh-server时仍然报错。详细分析如下:

安装openssh-server时,如果顺利的话会安装成功,如果遇到

1
2
3
4
5
6
7
8
9
10
11
12
$ sudo apt-get install openssh-server
正在读取软件包列表... 完成
正在分析软件包的依赖关系树      
正在读取状态信息... 完成      
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:
 
下列软件包有未满足的依赖关系:
 openssh-server : 依赖: openssh-client (= 1:6.6p1-2ubuntu1)
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

这是因为,openssh-server是依赖于openssh-clien的,那ubuntu不是自带了openssh-client吗?原由是自带的openssh-clien与所要安装的openssh-server所依赖的版本不同,这里所依赖的版本是

1
1:6.6p1-2ubuntu1

所以要安装对应版本的openssh-clien,来覆盖掉ubuntu自带的

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
$ sudo apt-get install openssh-client=1:6.6p1-2ubuntu1
正在读取软件包列表... 完成
正在分析软件包的依赖关系树      
正在读取状态信息... 完成      
建议安装的软件包:
  libpam-ssh keychain monkeysphere
下列软件包将被【降级】:
  openssh-client
升级了 0 个软件包,新安装了 0 个软件包,降级了 1 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
需要下载 566 kB 的软件包。
解压缩后会消耗掉 0 B 的额外空间。
您希望继续执行吗? [Y/n] y
获取:1 http://cn.archive.ubuntu.com/ubuntu/ trusty/main openssh-client amd64 1:6.6p1-2ubuntu1 [566 kB]
下载 566 kB,耗时 2秒 (212 kB/s)       
dpkg:警告:downgrading openssh-client from 1:6.6p1-2ubuntu2 to 1:6.6p1-2ubuntu1
(正在读取数据库 ... 系统当前共安装有 200015 个文件和目录。)
Preparing to unpack .../openssh-client_1%3a6.6p1-2ubuntu1_amd64.deb ...
Unpacking openssh-client (1:6.6p1-2ubuntu1) over (1:6.6p1-2ubuntu2) ...
Processing triggers for man-db (2.6.7.1-1) ...
正在设置 openssh-client (1:6.6p1-2ubuntu1) ...

可以看到,提示了系统中openssh-client被降级,这样再安装openssh-server就可以成功了!

此时,与openssh-server所对应的openssh-client版本正确了。那么下面就可以水到渠成的安装openssh-server



0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:23921次
    • 积分:486
    • 等级:
    • 排名:千里之外
    • 原创:24篇
    • 转载:12篇
    • 译文:0篇
    • 评论:0条
    文章分类