Find The Multiple(poj 1426)

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33035 Accepted: 13823 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source

这道题,好多人都是拿long long 就给过了,但是如果数据再大一点,用 long long 就过不了了。


首先我们得明白 每个数的二进制数 乘以 10;就等于他原来的十进制树乘以 2.


举个例子 : 1   二进制 1   如果 1 乘以 10等于10  那就是2的二进制,10*10=100 那就是4的二进制。那么一个十进制数除以2得到的数,他们在二进制里相差10倍。

还得明白      同余模定理


(a*b)%n = (a%n *b%n)%n;

(a+b)%n = (a%n +b%n)%n;

这些都懂了之后,这道题,就比较好理解了,我们主要就是枚举每一个数的二进制数,看看如果这是个十进制的,能不能是n的倍数。如果单纯的去求这样的二进制肯定会超出int 的范围。那么就需要同余模定理了。


#include<stdio.h>
int mod_er[1000000];  //这里必须开得足够大,才能满足能够枚举到这样的sh
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int ans[200];
        if(n==0)
            return 0;
        mod_er[1]=1;
        int i;
        for( i=2;mod_er[i-1]!=0;i++)
        {
             mod_er[i]=(mod_er[i/2]*10+i%2)%n;   //一个个的枚举每个数的二进制,是否满足条件。
        }
        i--;
        int k=0;
        while(i)
        {
            int temp=i%2;
            ans[k]=temp;
            k++;
            i=i/2;
        }
        for(int j=k-1;j>=0;j--)
        {
            printf("%d",ans[j]);
        }
        printf("\n");
    }
}


  • 3
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值