POJ 1164 The Castle

Description

 1   2   3   4   5   6   7 

#############################

1 # | # | # | | #

#####—#####—#—#####—#

2 # # | # # # # #

#—#####—#####—#####—#

3 # | | # # # # #

#—#########—#####—#—#

4 # # | | | | # #

#############################

(Figure 1)

= Wall

| = No wall
- = No wall

Figure 1 shows the map of a castle.Write a program that calculates
1. how many rooms the castle has
2. how big the largest room is
The castle is divided into m * n (m<=50, n<=50) square modules. Each such module can have between zero and four walls.

Input

Your program is to read from standard input. The first line contains the number of modules in the north-south direction and the number of modules in the east-west direction. In the following lines each module is described by a number (0 <= p <= 15). This number is the sum of: 1 (= wall to the west), 2 (= wall to the north), 4 (= wall to the east), 8 (= wall to the south). Inner walls are defined twice; a wall to the south in module 1,1 is also indicated as a wall to the north in module 2,1. The castle always has at least two rooms.

Output

Your program is to write to standard output: First the number of rooms, then the area of the largest room (counted in modules).

Sample Input

4
7
11 6 11 6 3 10 6
7 9 6 13 5 15 5
1 10 12 7 13 7 5
13 11 10 8 10 12 13

Sample Output

5
9

思路:求最大联通块。

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <vector>
#include <map>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <climits>

using namespace std;

int n,m,vis[60][60],s[60][60];

int check(int x,int y)
{
    if(x<=n && x>=1 && y<=m && y>=1 && !vis[x][y]) return 1;
    return 0;
}
int dfs(int x,int y,int cur)
{
    vis[x][y]=cur;
    int sum=1,temp=s[x][y];
    if(temp/8!=1 && check(x+1,y))
        sum+=dfs(x+1,y,cur);
    temp%=8;
    if(temp/4!=1 && check(x,y+1))
        sum+=dfs(x,y+1,cur);
    temp%=4;
    if(temp/2!=1 && check(x-1,y))
        sum+=dfs(x-1,y,cur);
    temp%=2;
    if(temp/1!=1 && check(x,y-1))
        sum+=dfs(x,y-1,cur);
    temp%=1;
    return sum;
}
int main(void)
{
    #ifdef LOCAL
        freopen("in.txt","rb",stdin);
        //freopen("out.txt","wb",stdout);
    #endif // LOCAL
    cin >> n >> m;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
            cin >> s[i][j];
    memset(vis,0,sizeof(vis));
    int maxm=0,tot=0;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
            if(!vis[i][j])
            {
                tot++;
                int v=dfs(i,j,tot);
                maxm=max(v,maxm);
            }
    cout << tot << endl << maxm;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值