poj 2506 Tiling

Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9183 Accepted: 4370

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source

提示

题意:

给你2*1和2*2的瓦片,问把2*n(0<=n<=250)铺满有几种情况?

思路:

详细解析.(要注意n=0时输出的是1.)

示例程序

Source Code

Problem: 2506		Code Length: 876B
Memory: 5564K		Time: 344MS
Language: Java		Result: Accepted
import java.math.*;
import java.util.*;
public class Main 
{
    public static void main(String[] args)
    {
        Scanner in = new Scanner(System.in);
        int n,i;
        BigInteger p,f1,f2,v;
        v=BigInteger.valueOf(2);
        while (in.hasNext())
        {
        	f1=BigInteger.valueOf(1);
            f2=BigInteger.valueOf(3);
            n=in.nextInt();
            if(n==1||n==0)
            {
            	System.out.println(f1);
            }
            else if(n==2)
            {
            	System.out.println(f2);
            }
            else
            {
            	p=f1.multiply(v).add(f2);
            	f1=f2;
            	f2=p;
            	for(i=4;n>=i;i++)
            	{
            		p=f1.multiply(v).add(f2);
            		f1=f2;
            		f2=p;
            	}
            	System.out.println(p);
            }
        }
    }
}
 

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值