poj 3267 The Cow Lexicon

The Cow Lexicon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9590 Accepted: 4603

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively:  W and  L 
Line 2:  L characters (followed by a newline, of course): the received message 
Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

Source

提示

题意:
很少有人知道,奶牛会有自己的字典和W个(1≤W≤600)词,每一个词由字符“a”到"z"组成。他们的cowmunication交流系统,是基于哞哞叫的基础上,并不能听懂在说什么;有时人们会听到似乎没有任何意义的话。例如,Bessie曾收到一个消息:“browndcodw”。之后才知道想要传达的信息是“browncow”,两个字母“d”是因为受到谷仓的干扰。
奶牛要你帮他们解密接收到的消息(字符“a”到"z")长度为L(2≤L≤300)。该消息有一些额外的字母,他们希望你用最少删除几个字母,使得一个或多个单词能从字典中提取出来解密(和主串完全匹配)。
思路:
DP,要解析 戳我。(我把变量放进main里会有莫名的BUG,答案一直不对,连样例都不能过,放到全局变量瞬间AC,我又学会了一招)

示例程序

Source Code

Problem: 3267		Code Length: 839B
Memory: 408K		Time: 204MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
int n,m,i,len[600],i1,l,k,dp[300];
char word[600][30],di[301];
int main()
{
    scanf("%d %d",&n,&m);
    scanf("%s",di);
    for(i=0;n>i;i++)
    {
        scanf("%s",word[i]);
        len[i]=strlen(word[i]);
    }
    dp[0]=1;
    for(i=1;m>i;i++)
    {
        dp[i]=dp[i-1]+1;
        for(i1=0;n>i1;i1++)
        {
            if(len[i1]-1>i)
            {
                continue;
            }
            l=len[i1]-1;
            k=i;
            while(k>=0&&l>=0&&k>=l)
            {
                if(word[i1][l]==di[k])
                {
                    l--;
                }
                k--;
            }
            if(dp[i]>dp[k]+i-k-len[i1]&&l<0)
            {
                dp[i]=dp[k]+i-k-len[i1];
            }
        }
    }
    printf("%d",dp[m-1]);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值