hdu 4911Inversion

Description

bobo has a sequence a 1,a 2,…,a n. He is allowed to swap two adjacent numbers for no more than k times.

Find the minimum number of inversions after his swaps.

Note: The number of inversions is the number of pair (i,j) where 1≤i<j≤n and a i>a j.
 

Input

The input consists of several tests. For each tests:

The first line contains 2 integers n,k (1≤n≤10 5,0≤k≤10 9). The second line contains n integers a 1,a 2,…,a n (0≤a i≤10 9).
 

Output

For each tests:

A single integer denotes the minimum number of inversions.
 

Sample Input

    
    
3 1 2 2 1 3 0 2 2 1
 

Sample Output

    
    
1 2
题意:
给你n个数a1,a2,a3...an,要你求出它的逆序数,但是可以交换相邻的两个数不超过k次,要你求出最小逆序数。
思路:
如果用普通的搜索肯定会超时,这时我们可以考虑用归并排序,参考算法竞赛与入门经典(第二版)中的P225-227,求出其逆序数,但这并不是最后的结果,因为题目要求是求出最小逆序数,我们可以这样想,每交换一次(相邻两个数前面的数比后面的数大),逆序数小于一,所以先求出未交换之前的逆序数,然后再减去k,如果逆序数大于0,这就是最后结果,如果小于0,说明最后交换肯定是达到从小到大的排列顺序,逆序数就为0.
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
int  A[500004],T[500004];
long long  cnt;
using namespace std;
void init(int n)
{
    for(int i=0;i<n;i++)
        scanf("%d",&A[i]);

}
void merge_sort(int *A,int x,int y,int *T)
{
    if(y-x>1)
    {
        int m=x+(y-x)/2;
        int p=x,q=m,i=x;
        merge_sort(A,x,m,T);
        merge_sort(A,m,y,T);
        while(p<m||q<y)
        {
            if(q>=y||(p<m&&A[p]<=A[q]))    T[i++]=A[p++];
            else
            {
                T[i++]=A[q++];
                cnt+=m-p;

            }

    }            for(i=x;i<y;i++)
                A[i]=T[i];
}
}
int main()
{
    int n,k;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
       init(n);
       cnt=0;
     memset(T,0,sizeof(T));
     merge_sort(A,0,n,T);//不能把n写成n-1,否则会答案错误
     if(cnt-k>=0)
        cnt=cnt-k;
     else
        cnt=0;
   printf("%I64d\n",cnt);
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值