UVA - 129 Krypton Factor : 回溯

题目点此跳转

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequenace of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called “easy”. Other sequences will be called “hard”.
 For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of thesubsequence CB. Other examples of easy sequences are:
 • BB
 • ABCDACABCAB
 • ABCDABCD
 Some examples of hard sequences are:
 • D
 • DC
 • ABDAB
 • CBABCBA
 In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines from standard input and will write to standard output.

Input

Each input line contains integers n and L (in that order), where n > 0 and L is in the range 1 ≤ L ≤ 26.
 Input is terminated by a line containing two zeroes.

Output

For each input line prints out the n-th hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (Alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is ‘A’. You may assume that for given n and L there do exist at least n hard sequences.
 As such a sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group.
 Your program may assume a maximum sequence length of 80.
 For example, with L = 3, the first 7 hard sequences are:
A
AB
ABA
ABAC
ABACA
ABACAB
ABACABA

Sample Input

7 3
30 3
0 0

Sample Output

ABAC ABA
7
ABAC ABCA CBAB CABA CABC ACBA CABA
28

思路

 题目意思是如果一个字符串包含两个相邻的重复子串,则称它是“容易的串”,其他串称为“困难的串”。例如,BB、ABCDACABCAB、ABCDABCD都是容易的串,而D、DC、ABDAB、CBABCBA都是困难的串。
 输入正整数n和L,输出由前L个字符组成的、字典序第k小的困难的串。

 从左到右枚举每一位上的字母,然后对于每一次枚举的结果就去判断是否符合条件,同时记录符合条件的结果的个数。当个数为所给个数时输出即可。

 而判断的时候,并不需要将当前字符串的所有偶数长度的相邻子串判断相等,因为在此之前,除了最后一个字母,前面的n-1个字母已经是合法的了,只需要再判断包含最后一个字母的偶数串即可,那么就是从最后长度为1的后缀开始判断到长度为len/2的后缀即可。

代码

#include <algorithm>
#include <iostream>
#include <sstream>
#include <utility>
#include <string>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <cstring>
#include <cstdio>
#include <cmath>
#define met(a,b) memset(a, b, sizeof(a));
#define IN freopen("in.txt", "r", stdin);
using namespace std;
typedef long long LL;
typedef pair<int, int> PII;
const int maxn = 1e4 + 100;
const int INF = 0x7fffffff;

int n, L, aid, ans[maxn], cnt;

bool check() {
    if(aid == 1) return 1;
    for(int i = 1; i <= aid/2; ++i) {
        bool ok = 0;
        for(int j = aid; j > aid-i; --j) {
            if(ans[j] != ans[j-i]) {ok = 1;break;}
        }
        if(!ok) return 0;
    }
    return 1;
}

bool dfs(int deep) {
    if(cnt >= n) {
        for(int i = 1; i <= aid; ++i) {
            printf("%c", ans[i]+'A');
            if(i%64==0) { if(i!=aid) printf("\n");}
            else if(i%4==0) if(i!=aid) printf(" ");
        }
        printf("\n%d\n", aid);
        return 1;
    }
    for(int i = 0; i < L; ++i) {
        ans[++aid] = i;
        if(check()) { ++cnt; if(dfs(deep+1)) return 1; }
        --aid;
    }
    return 0;
}

int main() {
    #ifdef _LOCAL
    IN;
    #endif // _LOCAL

    while(scanf("%d%d", &n, &L) == 2 && n) {
        aid = cnt = 0; dfs(0);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值