HDU1241 DFS/BFS 求连通块


0)

        遍历所有点,求出连通块的数量,每到一块油田,就采用DFS或者BFS消除该油田以及附近连通的油田。


        注意(易错):

               ①二维数组mat[i][j],i是第几行,j是第几列,所以搜到一点再搜该点周围八个方位(+dir[i][j])时,以及确定是否超出地图范围时,注意i是纵向加减,j是横向加减,且(0,0)原点在左上角,向右向下坐标的值都是不断递增。

               ②scanf("%c",&mat[i][j]);  ,  scanf读入%c的字符时,会出错!可改成cin>>,或者scanf("%s",&mat[i]),如果数组第二维从1开始就scanf("%s",&mat[i]+1),scanf依然比cin快。(见如下BFS代码中的使用)

1)

DFS

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>

using namespace std;
const int maxn=105;
char mat[maxn][maxn];
int dir[8][2]={{1,0},{-1,0},{0,1},{0,-1},{1,1},{-1,1},{1,-1},{-1,-1}};
int  m,n;
int sum;
void Dfs(int x,int y){
    int tx;
    int ty;
    for(int i=0;i<8;i++){
        tx=x+dir[i][0];
        ty=y+dir[i][1];
        if(1<=tx&&tx<=m&&1<=ty&&ty<=n){//注意!对于二维数组来说,x行y列,意味着x是纵向坐标,y是横向坐标
            if(mat[tx][ty]=='@'){
                mat[tx][ty]='*';
                Dfs(tx,ty);
            }
        }
    }
}
int main()
{
    while(scanf("%d%d",&m,&n)){
        if(m==0&&n==0){
            break;
        }
        //memset(mat,0,sizeof(mat));
        sum=0;
        for(int i=1;i<=m;i++){
            for(int j=1;j<=n;j++){
                //scanf("%s",mat[i]+1);
                cin>>mat[i][j];
                //scanf("%c",&mat[i][j]);
            }
        }
        for(int i=1;i<=m;i++){
            for(int j=1;j<=n;j++){
                if(mat[i][j]=='@'){
                    sum++;
                    mat[i][j]='*';
                    Dfs(i,j); //深搜,消除同一连通块的所有油田标记
                }
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}

BFS

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>


using namespace std;
const int maxn=105;
char mat[maxn][maxn];
int dir[8][2]={{1,0},{-1,0},{0,1},{0,-1},{1,1},{-1,1},{1,-1},{-1,-1}};
int  m,n;
int sum;
struct Node{
    int x;
    int y;
};
void Bfs(int x,int y){
    queue <Node> q;
    Node node;
    node.x=x;
    node.y=y;
    q.push(node);
    while(!q.empty()){
        Node cur=q.front();
        Node next;
        q.pop();
        for(int i=0;i<8;i++){
            next.x=cur.x+dir[i][0];
            next.y=cur.y+dir[i][1];
            if(mat[next.x][next.y]=='@'){
                mat[next.x][next.y]='*';
                q.push(next);
            }
        }
    }
}
int main()
{
    while(scanf("%d %d",&m,&n)){
        if(m==0&&n==0){
            break;
        }
        memset(mat,0,sizeof(mat));
        sum=0;
        int cur=1;
        for(int i=1;i<=m;i++){
            //for(int j=1;j<=n;j++){
                scanf("%s",mat[i]+1);//因为第二维也都是从1开始到n,所以+1开始
                //cin>>mat[i][j];
                //scanf("%c",&mat[i][j]);
            //}
        }
        for(int i=1;i<=m;i++){
            for(int j=1;j<=n;j++){
                if(mat[i][j]=='@'){
                    sum++;
                    mat[i][j]='*';
                    Bfs(i,j); //广搜,消除同一连通块的所有油田标记
                }
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}

2)

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
 

Sample Input

    
    
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output

    
    
0 1 2 2



  • 2
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,关于 HDU4992 所有原根的问题,我可以给出以下解答: 1. 首先,我们需要知道什么是原根。原根是指模 n 意义下,所有与 n 互质的数 a 的最小正整数 k 次幂对 n 取模的值覆盖了所有与 n 互质的数。简单来说,就是如果一个数 a 是模 n 意义下的原根,那么 a 的任何正整数次幂对 n 取模的值都不相同,且能覆盖所有与 n 互质的数。 2. 为了模 n 意义下的所有原根,我们需要先出与 n 互质的数的个数 phi(n)。phi(n) 可以使用欧拉函数出。 3. 然后,我们需要枚举模 n 意义下的所有数,判断它是否是原根。具体来说,对于每个 a,我们需要判断 a 的每个小于 phi(n) 的正整数次幂对 n 取模的值是否都不相同,且能覆盖所有与 n 互质的数。如果是,那么 a 就是模 n 意义下的原根。 4. 代码实现可以参考以下 Java 代码: ``` import java.util.*; public class Main { static int gcd(int a, int b) { return b == 0 ? a : gcd(b, a % b); } static int phi(int n) { int res = n; for (int i = 2; i * i <= n; i++) { if (n % i == 0) { res = res / i * (i - 1); while (n % i == 0) { n /= i; } } } if (n > 1) { res = res / n * (n - 1); } return res; } static int pow(int a, int b, int mod) { int res = 1; while (b > 0) { if ((b & 1) != 0) { res = res * a % mod; } a = a * a % mod; b >>= 1; } return res; } static boolean check(int a, int n, int phi) { for (int i = 1, j = pow(a, i, n); i <= phi; i++, j = j * a % n) { if (j == 1) { return false; } } return true; } public static void main(String[] args) { Scanner scanner = new Scanner(System.in); while (scanner.hasNext()) { int n = scanner.nextInt(); int phi = phi(n); List<Integer> ans = new ArrayList<>(); for (int i = 1; i < n; i++) { if (gcd(i, n) == 1 && check(i, n, phi)) { ans.add(i); } } Collections.sort(ans); for (int x : ans) { System.out.print(x + " "); } System.out.println(); } } } ``` 其中,gcd 函数用于最大公约数,phi 函数用于欧拉函数,pow 函数用于快速幂模,check 函数用于判断一个数是否是原根。在主函数中,我们依次读入每个 n,出 phi(n),然后枚举模 n 意义下的所有数,判断它是否是原根,将所有原根存入一个 List 中,最后排序输出即可。 希望我的回答能够帮到你,如果你有任何问题,欢迎随时提出。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值