POJ1509--Glass Beads

Description

Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the people loved her. But she was not interested in the crowds. Her big hobby were beads of any kind. Many bead makers were working for her and they manufactured new necklaces and bracelets every day. One day she called her main Inspector of Bead Makers (IBM) and told him she wanted a very long and special necklace.

The necklace should be made of glass beads of different sizes connected to each other but without any thread running through the beads, so that means the beads can be disconnected at any point. The actress chose the succession of beads she wants to have and the IBM promised to make the necklace. But then he realized a problem. The joint between two neighbouring beads is not very robust so it is possible that the necklace will get torn by its own weight. The situation becomes even worse when the necklace is disjoined. Moreover, the point of disconnection is very important. If there are small beads at the beginning, the possibility of tearing is much higher than if there were large beads. IBM wants to test the robustness of a necklace so he needs a program that will be able to determine the worst possible point of disjoining the beads.

The description of the necklace is a string A = a1a2 ... am specifying sizes of the particular beads, where the last character am is considered to precede character a1 in circular fashion.

The disjoint point i is said to be worse than the disjoint point j if and only if the string aiai+1 ... ana1 ... ai-1 is lexicografically smaller than the string ajaj+1 ... ana1 ... aj-1. String a1a2 ... an is lexicografically smaller than the string b1b2 ... bn if and only if there exists an integer i, i <= n, so that aj=bj, for each j, 1 <= j < i and ai < bi

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line containing necklace description. Maximal length of each description is 10000 characters. Each bead is represented by a lower-case character of the english alphabet (a--z), where a < b ... z.

Output

For each case, print exactly one line containing only one integer -- number of the bead which is the first at the worst possible disjoining, i.e.\ such i, that the string A[i] is lexicographically smallest among all the n possible disjoinings of a necklace. If there are more than one solution, print the one with the lowest i.

Sample Input

4
helloworld
amandamanda
dontcallmebfu
aaabaaa

Sample Output

101165

 

后缀自动机解法:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 20080
char str[maxn];
struct SAM
{
    SAM *pre,*son[26];
    int len,g;
}que[maxn],*root,*tail,*b[maxn];
int tot;

void add(int c,int l)
{
    SAM *p=tail,*np=&que[tot++];
    np->len=l;tail=np;
    while(p&&p->son[c]==NULL) p->son[c]=np,p=p->pre;
    if(p==NULL) np->pre=root;
    else
    {
        SAM *q=p->son[c];
        if(p->len+1==q->len) np->pre=q;
        else
        {
            SAM *nq=&que[tot++];
            *nq=*q;
            nq->len=p->len+1;
            np->pre=q->pre=nq;
            while(p&&p->son[c]==q) p->son[c]=nq,p=p->pre;
        }
    }
}

void init(int n)
{
	tot = 0;
	for(int i = 0;i < n;i++)
	{
		que[i].g = 0;	que[i].pre = NULL;
		memset(que[i].son,0,sizeof(que[i].son));
	}
	root = tail = &que[tot++];
}

int main()
{
	//freopen("in.txt","r",stdin);
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",str);
		int len = strlen(str);
		init(len<<1);
		for(int i = 0;i < len;i++)
		{
			add(str[i] - 'a',i+1);
		}
		for(int i = 0;i < len;i++)
		{
			add(str[i] - 'a',i+len+1);
		}
		SAM * now = &que[0];
		for(int i = 0;i < len;i++)
		{
			for(int j = 0;j < 26;j++)
			{
				if(now -> son[j] != NULL)
				{
					now = now -> son[j];
					break;
				}
			}
		}
		printf("%d\n",now -> len - len + 1);
	}
	return 0;
}


 

 

最小表示法:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAXN 100000
int min(int a,int b)
{
    return a<b?a:b;
}
int min_Str(char *str)
{
    int i,j,k,len=strlen(str);
    i=0,j=1;
    memcpy(str+len,str,len);
    while(j<len&&i<len)
    {
        k=0;
        while(str[i+k]==str[j+k])
        k++;
        if(k>=len)
        break;
        if(str[i+k]>str[j+k])
        i=i+k+1;
        else
        j=j+k+1;
        if(i==j)
        j++;
    }
    return min(i,j);
}
char str[MAXN];
int main()
{   //freopen("dd.txt","r",stdin);
    int ncase;
    scanf("%d",&ncase);
    while(ncase--)
    {   memset(str,'\0',sizeof(str));
        scanf("%s",str);
        printf("%d\n",1+min_Str(str));
    }
    return 0;
}



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值