.format(x=modname), ExtDeprecationWarning的原因

原创 2016年08月30日 19:56:18

    最近用flask发现老是出现:

  .format(x=modname), ExtDeprecationWarning
C:\Users\Administrator\version\lib\site-packages\flask\exthook.py:71: ExtDepreca
tionWarning: Importing flask.ext.moment is deprecated, use flask_moment instead.

  .format(x=modname), ExtDeprecationWarning
C:\Users\Administrator\version\lib\site-packages\flask\exthook.py:71: ExtDepreca
tionWarning: Importing flask.ext.sqlalchemy is deprecated, use flask_sqlalchemy
instead.
  .format(x=modname), ExtDeprecationWarning
C:\Users\Administrator\version\lib\site-packages\flask\exthook.py:71: ExtDepreca
tionWarning: Importing flask.ext.mail is deprecated, use flask_mail instead.
  .format(x=modname), ExtDeprecationWarning
C:\Users\Administrator\version\lib\site-packages\flask\exthook.py:71: ExtDepreca
tionWarning: Importing flask.ext.login is deprecated, use flask_login instead.
  .format(x=modname), ExtDeprecationWarning
C:\Users\Administrator\version\lib\site-packages\flask\exthook.py:71: ExtDepreca
tionWarning: Importing flask.ext.pagedown is deprecated, use flask_pagedown inst
ead.
  .format(x=modname), ExtDeprecationWarning
    后来一查才发现是https://github.com/MongoEngine/flask-mongoengine/issues/222

    也就是把所有flask.ext.XXX改写成flask_XXX,这应该是flask1.1的新规定吧。


版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

ExtDeprecationWarning: Importing flask.ext.bootstrap is deprecated, use flask_bootstrap instead.

此错误信息出现在对 flask 进行拓展时导入包的方式上,以下导入包的方式将会产生该错误信息,from flask.ext.script import Manager from flask.ext.b...

初用pycharm测试flask时常见报错

使用flask.ext时出错 出错信息:ExtDeprecationWarning: Importing flask.ext.bootstrap is deprecated, use flask...

PALSAR_x_Format_EK.pdf

  • 2009-05-10 13:06
  • 866KB
  • 下载

Linux 2.6.x 内核模块加载错误 “Invalid module format” 解决办法

问 题: 可以正常编译我写的驱动模块,但是加载(insmod)的时候提示错误: insmod: error inserting 'xxx.ko': -1 Invalid module format;用...

Format 函数,%f,%d,%x,%p

Format函数:返回按指定方式格式化一个数组常量的字符形式。 "%" [索引 ":"] ["-"] [宽度] ["." 摘要] 类型 Format('x=%d', [12]);  ...

ppp = 2.4.4 is needed by pptpd-1.3.4-2.rhel5.x86_64的解决办法及原因

“ppp = 2.4.4 is needed by pptpd-1.3.4-2.rhel5.x86_64”或者“ppp = 2.4.4 is needed by pptpd-1.3.4-2.rhe...

解决error while loading shared libraries: xxx.so.x"类似问题办法和错误原因

解决error while loading shared libraries: xxx.so.x"类似问题办法和错误原因 编译Tengine时,执行make命令,出现以下错误: error w...

error while loading shared libraries: xxx.so.x"错误的原因和解决办法

一般我们在Linux下执行某些外部程序的时候可能会提示找不到共享库的错误, 比如: tmux: error while loading shared libraries: libevent-...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)