poj 3670 Eating Together LIS+二分

http://poj.org/problem?id=3670

 

Eating Together
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4583 Accepted: 2233

Description

The cows are so very silly about their dinner partners. They have organized themselves into three groups (conveniently numbered 1, 2, and 3) that insist upon dining together. The trouble starts when they line up at the barn to enter the feeding area.

Each cow i carries with her a small card upon which is engraved Di(1 ≤Di≤ 3) indicating her dining group membership. The entire set of N (1 ≤N ≤ 30,000) cows has lined up for dinner but it's easy for anyone to see that they are not grouped by their dinner-partner cards.

FJ's job is not so difficult. He just walks down the line of cows changing their dinner partner assignment by marking out the old number and writing in a new one. By doing so, he creates groups of cows like 111222333 or 333222111 where the cows' dining groups are sorted in either ascending or descending order by their dinner cards.

FJ is just as lazy as the next fellow. He's curious: what is the absolute mminimum number of cards he must change to create a proper grouping of dining partners? He must only change card numbers and must not rearrange the cows standing in line.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i describes the i-th cow's current dining group with a single integer:Di

Output

* Line 1: A single integer representing the minimum number of changes that must be made so that the final sequence of cows is sorted in either ascending or descending order

Sample Input

5
1
3
2
1
1

Sample Output

1

 

自己刚学..借鉴了别人很好的作法...

整体思路是求出最长不减序列和最长不增序列中较大的.再用总数减去它就行了 .

求最长不减序列时,用一个数组stack保存和更新(更新操作就是使数组中对应位置的元素尽量小,使插入新元素的条件(大小)降到最低,从而求出最长的序列数目)

#include <stdio.h>
#define max  30002

int n,CowNu[max],stack[max];

int bsearch(int size ,int value)
{
	int left=1,mid;
	int right=size;
	while(left<=right)
	{
		mid=(left+right)>>1;
		if(stack[mid]<=value&&stack[mid+1]>value)
			return mid+1;	// >&&<= 换为: >= && <  后者为最长不减子序列
		if(value<stack[mid])      //注意
		    right=mid-1;
		else 
			left=mid+1;	
	}
}

int LIS1()
{
	int i,j;
	int size=1;
	stack[1]=CowNu[0];
	for(i=1;i<n;i++)
	{
		if(CowNu[i]<stack[1])     
			j=1;				//<=换为<  后者为最长不减子序列
		else if(CowNu[i]>=stack[size])
			j=++size;			// > 换为: >=  后者为最长不减子序列
		else 
			j=bsearch(size,CowNu[i]);
		stack[j]=CowNu[i];
	}
	return size;
}

int LIS2()           //反向递增等于正向的递减
{
	int i,j;
	int size=1;
	stack[1]=CowNu[n-1];
	for(i=n-2;i>=0;i--)
	{
		if(CowNu[i]<stack[1])
			j=1;
		else if(CowNu[i]>=stack[size])
			j=++size;
		else 
			j=bsearch(size,CowNu[i]);
		stack[j]=CowNu[i];
	}
	return size;
}

int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)
		scanf("%d",&CowNu[i]);
	printf("%d\n",n-(LIS1()>LIS2()?LIS1():LIS2()));
	return 0;
}


 

 

看到某位大牛的代码很简洁,总结思路如下

以lis为例

设a为读取到的数,f[i][j]为前i个数且所有成员<=j时的最长lis长度,则有:

    f[i][1]=f[i-1]+(a==1);

   f[i][2]=max{f[i][1],f[i-1][2]}+(a==2);

    f[i][3]=max{f[i][2],f[i-1][3]}+(a==3);

然后进行优化可得如下代码

#include"stdio.h"
#include"stdlib.h"
int max(int a,int b)
{return a>b?a:b;}
main()
{
      int n,f[4]={0},g[4]={0},a,i;
      scanf("%d",&n);
      i=n;
      while(i--)
      {
                scanf("%d",&a);
                ++f[a],++g[a];
                if(f[2]<f[1])f[2]=f[1];
                if(f[3]<f[2])f[3]=f[2];
                if(g[2]<g[3])g[2]=g[3];
                if(g[1]<g[2])g[1]=g[2];
      }
      printf("%d\n",n-max(f[3],g[1]));
      
      return 0;
      }


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值