ZOJ1608-Two Circles and a Rectangle

120 篇文章 1 订阅

Two Circles and a Rectangle

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Give you two circles and a rectangle, your task is to judge wheather the two circles can be put into the rectangle with no part of circles outside the retangle.


Input

There are multiple test cases. In every test cast, there are four float-point numbers:

a, b, r1, r2

where, a and b are two sides of the rectangle, r1 and r2 are radii of the two circls.


Output

Print a "Yes", if the circles can be put into the rectangle. Otherwise, print a "No".

You can safely assume x < y, where x and y are float-point numbers, if x < y + 0.01.


Sample Input

5 4 1 1
5 4 1.5 2


Sample Output

Yes
No



Author:  CHEN, Gaoli
Source:  ZOJ Monthly, May 2003


题意:问两个圆是否能放进一个长方形里

解题思路:两个圆对角放


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

int main()
{
    double a,b,r1,r2;
    while(~scanf("%lf%lf%lf%lf",&a,&b,&r1,&r2))
    {
        double x=(a-r1-r2);
        double y=(b-r1-r2);
        if(x<0.01||y<0.01) {printf("No\n");continue;}
        if(sqrt(x*x+y*y)+0.01>(r1+r2)) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值