hdu 1718(水题)

Rank


Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4270    Accepted Submission(s): 1654




Problem Description
Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the second best mark(or is tied) his rank is 2, and so on.
 


Input
The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000 and 99999999 and a mark between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.
 


Output
For each test case, output a line giving Jackson’s rank in the class.
 


Sample Input
20070101
20070102 100
20070101 33
20070103 22
20070106 33
0 0
 


Sample Output

2

求已给学号的名次

#include <stdio.h>
#include <algorithm>
using namespace std;
struct st
{
    int a;
    int score;
}p[1010];
bool cmp(st a,st b)
{
    return a.score>b.score;
}
int main()
{
    int n;
    while(~scanf("%d",&n)) //注意多组数据
    {
        int c,d,cnt=0;
        int t;
        while(scanf("%d%d",&c,&d)&&(c+d))
        {
            p[cnt].a=c;
            p[cnt].score=d;
            cnt++;
            if(c==n)
                t=d;
        }
        sort(p,p+cnt,cmp);
        for(int i=0;i<cnt;i++)
        {
            if(p[i].score==t)
            {
                printf("%d\n",i+1);
                break;
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值