xtu 1264 Partial Sum 2017湘潭邀请赛E

Partial Sum

Bobo has a integer sequence a1,a2,,an of length n. Each time, he selects two ends 0l<rn and add |rj=l+1aj|C into a counter which is zero initially. He repeats the selection for at most m times.

If each end can be selected at most once (either as left or right), find out the maximum sum Bobo may have.

Input

The input contains zero or more test cases and is terminated by end-of-file. For each test case:

The first line contains three integers nmC. The second line contains n integers a1,a2,,an.

  • 2n105
  • 12mn+1
  • |ai|,C104
  • The sum of n does not exceed 106.

Output

For each test cases, output an integer which denotes the maximum.

Sample Input

4 1 1
-1 2 2 -1
4 2 1
-1 2 2 -1
4 2 2
-1 2 2 -1
4 2 10
-1 2 2 -1

Sample Output

3
4
2
0

#include <stdio.h>
#include <algorithm>
#include <vector>
#include <string.h>
#include <queue>
#include <cmath>
using namespace std;
 
#define ll __int64
const int N=100005;
 
int main()
{
    ll n,m,c,a,sum[N];
    while(~scanf("%I64d %I64d %I64d",&n,&m,&c))
    {
        sum[0]=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%I64d",&a);
            sum[i]=sum[i-1]+a;
        }
        sort(sum,sum+n+1);
        int l=n,s=0;
        ll ans=0;
        for(int i=0; i<m; i++)
        {
            ll t=abs(sum[n-i]-sum[i])-c;
            if(t<=0) break;
            ans+=t;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值