HDU——1397Goldbach's Conjecture(二分查找+素数打表)

Goldbach's Conjecture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5567    Accepted Submission(s): 2151


Problem Description
Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.
 


 

Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.
 


 

Output
Each output line should contain an integer number. No other characters should appear in the output.
 


 

Sample Input
  
  
6 10 12 0
 


 

Sample Output
  
  
1 2 1

题意:给定一个小于2^15的偶n数,求符合p1+p2=n的(p1,p2)有几对。p1,p2与p2,p1视为相同

刚开始想错了,以为p1,p2相同的话实际只需到2^14次即可,后来发现若我p1很小,p2将会很大,早超过2^14了,2^14只是p1的取值范围,实际还得2~2^15。

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;

bool prime(const int &n)
{
	if(n==1)
		return false;
	else if(n==2)
		return true;
	else
	{
		for (int i=2; i*i<=n; i++)
			if(n%i==0)
				return false;
	}
	return true;
}

bool sea(const int list[],const int &len,const int &a)
{
	int l=1,r=len-1;
	int mid;
	while (l<=r)
	{
		mid=(l+r)/2;
		if(list[mid]==a)
			return true;
		else if(list[mid]>a)
		{
			r=mid-1;
		}
		else if(list[mid]<a)
		{
			l=mid+1;
		}
	}
	return false;
}

int main(void)
{
	int list[3514]={0},i,k=1;
	for (i=2; i<=32768; i++)//调试后发现最接近32768的质数在list[3513]处,则数组范围改小,节省空间
	{
		if(prime(i))
			list[k++]=i;
	}
	int n,ans;
	while (~scanf("%d",&n)&&n>=4)
	{
		ans=0;
		for (i=1; list[i]<=n/2; i++)遍历p1
		{
			if(sea(list,3514,n-list[i]))//找另一半p2
				ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}


 


 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值