POJ——3159Candies(差分约束SPFA+前向星+各种优化)

29 篇文章 0 订阅
26 篇文章 0 订阅

Candies
Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 28071 Accepted: 7751

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers ABand c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

本来看一道组合数学问题的,莫名其妙看到差分约束了(不明觉厉,这是什么算法!??),一看用到了我喜欢的SPFA,就研究了一下,原来SPFA还可以这么用。

这题比较坑爹,用优先队列spfa超时,自带queue也超时,用栈的spfa才1400+MS险过,后来用数组模拟了个栈。1100+MS。还有用到一个叫前向星的数据结构,也是用来储存图的,可以代替vector的邻接表,然而这东西还是有一点点麻烦的,看了一篇关于这个东西的博客之后才懂了一点。

向前星主要思想:用一个结构体数Edge[MAX_E]组记录每一条边的长度dx(边权),每一条边的终点to,每一条边的起点对应上一条边所在的结构体数组中的下标(有一点pre的意思),综上,可以得到一个结构体数组Edge[N],其中每一个元素都是一条边,其包含了边的终点,边权,边的起点对应的上一条边所在的下标。然后这样会发现还是缺少了什么——一个给出线索的数组,就是说你如何对一个起点进行遍历?显然上面的结构体数组是没有记录自身起点的数据而只有上一条边起点数据,无法得知到底从哪里开始,因此需要再来一个head数组来记录所有起点对应的最后出现的那条边所在Edge[MAX_E]中的位置i,这样一来就可以用head开头而后用pre来进行遍历,不过实践起来还是需要更多的理解的。

代码:

#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<sstream>
#include<cstring>
#include<cstdio>
#include<string>
#include<deque>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>
#define INF 0x3f3f3f3f
#define MM(x) memset(x,0,sizeof(x))
using namespace std;
typedef long long LL;
typedef pair<int,int> pii;
const int N=30010;

struct info
{
	int to;
	int dx;
	int pre;
};
info E[5*N];
int heads[5*N];
int d[N],vis[N];
int Q[N],rear;

inline void init()
{
	MM(E);
	memset(heads,-1,sizeof(heads));
	memset(d,INF,sizeof(d));
	memset(vis,0,sizeof(vis));
	rear=0;
}
inline void add(const int &s,const int &t,const int &dx,int &cnt)
{
	E[cnt].to=t;
	E[cnt].dx=dx;
	E[cnt].pre=heads[s];
	heads[s]=cnt++;
}
inline int Scan()
{
    int res = 0, ch, flag = 0;

    if((ch = getchar()) == '-')             
        flag = 1;

    else if(ch >= '0' && ch <= '9')
        res = ch - '0';
    while((ch = getchar()) >= '0' && ch <= '9' )
        res = res * 10 + ch - '0';

    return flag ? -res : res;
}

int main(void)
{
	int n,m,a,b,c,i,j,ori,cnt;
	while (~scanf("%d%d",&n,&m))
	{
		init();
		cnt=0;
		for (i=0; i<m; i++)
		{
			a=Scan();
			b=Scan();
			c=Scan();
			add(a,b,c,cnt);
		}
		d[1]=0;
		vis[1]=1;
		Q[rear++]=1;
		while (rear)
		{
			int now=Q[rear-1];
			rear--;
			vis[now]=0;
			for(i=heads[now]; i!=-1; i=E[i].pre)
			{
				int v=E[i].to;
				if(d[v]>d[now]+E[i].dx)
				{
					d[v]=d[now]+E[i].dx;
					if(!vis[v])
					{
						Q[rear++]=v;
						vis[v]=1;
					}
				}
			}
		}
		printf("%d\n",d[n]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值