nyoj 323 BUYING FEED 贪心

题目:

BUYING FEED

时间限制:3000 ms  |  内存限制:65535 KB

难度:4

描述

Farmer John needs to travel to town to pick up K (1 <= K <= 100)pounds of feed. Driving D miles with K pounds of feed in his truck costs D*K cents.

The county feed lot has N (1 <= N<= 100) stores (conveniently numbered 1..N) that sell feed. Each store is located on a segment of the X axis whose length 

is E (1 <= E <= 350). Store i is at location X_i (0 < X_i < E) on the number line and can sell John as much as F_i (1 <= F_i <= 100) pounds of feed at a cost of

 C_i (1 <= C_i <= 1,000,000) cents per pound.
Amazingly, a given point on  the X axis might have more than one store.

Farmer John  starts  at location 0 on this number line and can drive only in the positive direction, ultimately arriving at location E, with at least K pounds of feed

 He can stop at any of the feed stores along the way and buy any amount of feed up to the the store's limit.  What is the minimum amount Farmer John has to

 pay to buy and transport the K pounds of feed? Farmer John
knows there is a solution. Consider a sample where Farmer John  needs two pounds of feed from three stores (locations: 1, 3, and 4) on a number line whose 

range is 0..5:     
0   1   2  3   4   5    
---------------------------------         
1       1   1                Available pounds of feed         
1       2   2               Cents per pound

It is best for John to buy one pound of feed from both the second and third stores. He must pay two cents to buy each pound of feed for a total cost of 4. When

John travels from 3 to 4 he is moving 1 unit of length and he has 1 pound of feed so he must pay1*1 = 1 cents.

When John travels from 4 to 5 heis moving one unit and he has 2 pounds of feed so he must pay 1*2 = 2 cents. The total cost is 4+1+2 = 7 cents.

输入

The first line of input contains a number c giving the number of cases that follow
There are multi test cases ending with EOF.
Each case starts with a line containing three space-separated integers: K, E, and N
Then N lines follow :every line contains three space-separated integers: Xi Fi Ci

输出

For each case,Output A single integer that is the minimum cost for FJ to buy and transport the feed

样例输入

1

2 5 3                 

3 1 2

4 1 2

1 1 1

样例输出

7

来源

第三届河南省程序设计大赛

题目大意:

你需要在一条长为e的数轴上的n个商店买至少k磅食物,第i个商店在Xi的位置,最多可以卖Fi磅食物,每磅Ci元。从0处出发,每带着1磅食物每前进一个单位,就要额外花费1元。求最小花费是多少。

题目思路:

1、因为要从买的的地方带到终点去,所以可以计算每个商店的单位费用ci+(e-xi)

2、利用贪心思想,所以将所有商店费用从小到大排序.先拿小的.直到拿够了

题目优化

1、用结构体和sort排序

程序:

 

 

 
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<cmath>
#include<algorithm>
#include <fstream>
#include <limits>
#include <vector>
#include <list>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <cassert>
using namespace std;
int len;
struct la
{
    int w,f,s;
}a[10010];
bool cmp(la x,la y)
{
    return x.f+(len-x.w)<y.f+(len-y.w);//自定义比较
}
int main()
{
    int t,need,m,n,i,j,k;
    scanf("%d",&t);
    while(t--)
    {
        int mai=0,da=0;
        scanf("%d %d %d",&need,&len,&m);
        for(i=0;i<m;i++)
        {
            scanf("%d %d %d",&a[i].w,&a[i].s,&a[i].f);
        }
        sort(a,a+m,cmp);
        for(i=0;mai<need;i++)
        {
            if(mai+a[i].s<=need)//
            {
                da+=a[i].s*(a[i].f+(len-a[i].w));
                mai+=a[i].s;
            }
            else//商店商品多于要的
            {
                da+=(need-mai)*(a[i].f+(len-a[i].w));
                mai=need;
            }
        }
        printf("%d\n",da);
    }
return 0;
}
        

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值