HDU 1003.Max Sum【最大连续子序列和】【8月14】

Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

就是让你求一个数组中,连续最大的子序列和,以及起始位置,终止位置。之前做过子序列和,就是用数组存前多少项的和,需要i~~j的子序列和,就用f[j]-f[i-1]就可以了。最大子序列和,只需得到前n项和的最大值,以及最小值就可以了。但是在维护的过程中发现,直接做,最小值可能出现在最大值之后,导致WA。修改了多次也没有AC,不得不另找方法。

思路:跟上面改变的不多,前n项和为负数的时候,就从第n+1项继续寻找最大值。代码如下:

#include<cstdio>
int main(){
    int T,kase=1,n,x;
    scanf("%d",&T);
    while(T--){
        int sum=0,maxsum=-9999,start=0,end=0,t=1;//start记录起点,end记录终点,t记录模拟起点
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d",&x);
            sum+=x;
            if(sum>maxsum){
                maxsum=sum;
                start=t;
                end=i;
            }
            if(sum<0){//前i项为负数,从第i+1项重新做
                sum=0;
                t=i+1;
            }
        }
        if(kase>1) printf("\n");
        printf("Case %d:\n%d %d %d\n",kase++,maxsum,start,end);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值