关闭

Google将不再支持Android Eclipse Tools

23人阅读 评论(0) 收藏 举报

爱盈利每天资讯:

近日,Google宣布将在年底前停止对Eclipse Android开发工具的一切支持。


在Android Studio 1.0版发布时,Google就宣布将其作为官方的Android开发工具,并建议开发者转向Android Studio。对于那些还没有转向Android Studio的开发者来说,现在则不得不面对这个问题了,因为Google已经宣布将在今年底终止Eclipse Android工具的开发与支持。这包括ADT插件、Ant构建系统、DDMS、Traceview与其他性能和监控工具。

要想从Eclipse迁移到Android Studio,推荐阅读这份迁移指南来理解新的项目结构以及如何通过Gradle构建Android项目。如果满足先决条件,那么可以使用Android Studio导入Eclipse项目,然后执行验证(构建与运行)来确保一切都是正确的。如果有问题,Google建议调整一下Eclipse ADT项目,然后再次导入。

建议那些还想继续使用Eclipse的开发者们看看Andmore项目并参与进去,该项目旨在让Android工具能够继续在Eclipse中发挥作用。Andmore包含了JDT、CDT与ADT,并且支持Maven与Ant,同时还计划对Gradle提供支持,它现在可以与Mylyn、EGit与GitHub集成。

众所周知,Google启动了很多项目,提出了很多大胆的创新,不过很多时候都会轻易扼杀一个事实证明不可行的项目,Reader、Wave、Buzz、Knol、Code、Dart Editor以及Chrome Dev Editor等莫不如此。这与很多软件开发者的做法大相径庭,后者会对那些缺乏动力的项目采取跟进的方式,从而确保项目能够重现生机。虽然Google的这种灵活的做法已经融入到了公司的DNA当中,但很多开发社区对此还是感到非常不舒服。我们看到了很多开发者的评论,他们不愿意参与Google的新项目,因为担心没几天项目就被终止了,延缓了这类项目的使用率。Google应该改变一下他们做事的方式么,还是说开发者应该更灵活一些呢?更多资讯请关注爱盈利,专门为盈利人士准备的资讯,让每个人都盈利.
0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:25次
    • 积分:2
    • 等级:
    • 排名:千里之外
    • 原创:0篇
    • 转载:1篇
    • 译文:0篇
    • 评论:0条
    文章存档