hdu 1016 Prime Ring Problem(DFS)

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31801    Accepted Submission(s): 14059


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
Asia 1996, Shanghai (Mainland China)

简单的DFS。。。。。
#include<stdio.h>
#include<string.h>
int isprime(int x){    //判断是否为素数
    int i,j;
    if(x==1)return 0;
    if(x==2)return 1;
    for(i=2;i<x;i++)
    if(x%i==0)return 0;
    return 1;
}
int n,vis[30],p[30];
void  dfs(int a,int cnt)    //a为当前的数,cnt标记当前的第几个数
{
    int i;

    p[cnt]=a;
    if(cnt==n&&isprime(p[1]+a)){    //判断是否到最后一个数了,判断最后一个数与第一个数相加是否为素数
        for(i=1;i<cnt;i++)
        printf("%d ",p[i]);
        printf("%d",p[cnt]);
        printf("\n");
        return ;
    }
    for(i=1;i<=n;i++)
    {
        if(!vis[i]&&isprime(a+i)){
        vis[i]=1;
        dfs(i,cnt+1);
        vis[i]=0;   //回溯
        }
    }
    return ;
}
int main()
{
    int i,j,k,t;
     t=1;
    while(scanf("%d",&n)!=EOF)
    {
        memset(vis,0,sizeof(vis));
      vis[1]=1;
       printf("Case %d:\n",t);
       dfs(1,1);
       printf("\n");
       t++;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值