安装Oracle 11g client(32bit)错误分析(后续)

原创 2015年07月09日 16:23:41
昨天安装client时采用了InstantClient模式进行安装,今天讲昨天的客户端删掉,重新以administrator模式安装,但是又碰到了几个问题,下面看具体问题分析及处理过程:

首先,将原来的ORACLE_HOME和oraInventory目录删除,然后重新安装,并选择administrator模式,前面都很顺利,安装到65%的时候,报错了:



进入log目录查看安装日志,没有发现什么有价值的东西,与图形中的提示一致:

INFO: make: *** [ntcontab.o] Error 1

INFO: End output from spawned process.
INFO: ----------------------------------
INFO: Exception thrown from action: make
Exception Name: MakefileException
Exception String: Error in invoking target 'mkldflags ntcontab.o nnfgt.o' of makefile '/oracle/client_1/network/lib/ins_net_client.mk'. See '/home/oracle/oraInventory/logs/installActions2015-07-09_11-03-57AM.log' for details.

google了一下,网上有人说是因为gcc的包没有安装完全所致,

# rpm -ivh glibc-common-2.12-1.25.el6.x86_64.rpm
# rpm -ivh kernel-headers-2.6.32-131.0.15.el6.x86_64.rpm
# rpm -ivh libgcc-4.4.5-6.el6.x86_64.rpm
# rpm -ivh glibc-2.12-1.25.el6.x86_64.rpm
# rpm -ivh libgomp-4.4.5-6.el6.x86_64.rpm
# rpm -ivh nscd-2.12-1.25.el6.x86_64.rpm
# rpm -ivh glibc-headers-2.12-1.25.el6.x86_64.rpm 
# rpm -ivh glibc-devel-2.12-1.25.el6.x86_64.rpm 
# rpm -ivh mpfr-2.4.1-6.el6.x86_64.rpm
# rpm -ivh ppl-0.10.2-11.el6.x86_64.rpm
# rpm -ivh cloog-ppl-0.15.7-1.2.el6.x86_64.rpm
# rpm -ivh cpp-4.4.5-6.el6.x86_64.rpm
# rpm -ivh gcc-4.4.5-6.el6.x86_64.rpm
=======================================
# rpm -ivh libstdc++-4.4.5-6.el6.x86_64.rpm
# rpm -ivh libstdc++-devel-4.4.5-6.el6.x86_64.rpm
# rpm -ivh gcc-c++-4.4.5-6.el6.x86_64.rpm
===========================================

网上某篇文章中提到,按照从上到下的顺序,将gcc和gcc-c++两个包都安装完即可,但是我查看过我的环境,以上这些包除了nscd-2.12-1.25.el6.x86_64.rpm没有安装外,别的都已经是安装好了的,于是先将nscd包安装好

[root@Ptyjkweb Packages]# ls -l|grep nscd
-r--r--r--.  57 root root   207480 Nov  9  2011 nscd-2.12-1.47.el6.x86_64.rpm
[root@Ptyjkweb Packages]# rpm -ivh nscd-2.12-1.47.el6.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:nscd                   ########################################### [100%]
[root@Ptyjkweb Packages]# rpm -qa|grep nscd
nscd-2.12-1.47.el6.x86_64

点击重试,问题依旧,因此说明此错误和没有装nscd包并没有关系,也不是gcc包没装好,于是用yum方式再次安装一下所有的11g client所需的包

[root@Ptyjkweb Packages]# yum install binutils-2.* compat-libstdc++-33* elfutils-libelf-0.* elfutils-libelf-devel-* gcc-4.* gcc-c++-4.* glibc-2.* glibc-common-2.* glibc-devel-2.* glibc-headers-2.* ksh-2* libaio-0.* libaio-devel-0.* libgcc-4.* libstdc++-4.* libstdc++-devel-4.* make-3.* sysstat-7.* unixODBC-2.* unixODBC-devel-2.* pdksh*
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
Updating certificate-based repositories.
Setting up Install Process
Examining binutils-2.20.51.0.2-5.28.el6.x86_64.rpm: binutils-2.20.51.0.2-5.28.el6.x86_64
binutils-2.20.51.0.2-5.28.el6.x86_64.rpm: does not update installed package.
Examining compat-libstdc++-33-3.2.3-69.el6.i686.rpm: compat-libstdc++-33-3.2.3-69.el6.i686
Marking compat-libstdc++-33-3.2.3-69.el6.i686.rpm to be installed
Package compat-libstdc++-33-3.2.3-69.el6.i686 already installed and latest version
compat-libstdc++-33-3.2.3-69.el6.i686.rpm: does not update installed package.
Examining compat-libstdc++-33-3.2.3-69.el6.x86_64.rpm: compat-libstdc++-33-3.2.3-69.el6.x86_64
Marking compat-libstdc++-33-3.2.3-69.el6.x86_64.rpm to be installed
Package compat-libstdc++-33-3.2.3-69.el6.x86_64 already installed and latest version
compat-libstdc++-33-3.2.3-69.el6.x86_64.rpm: does not update installed package.
Examining elfutils-libelf-0.152-1.el6.i686.rpm: elfutils-libelf-0.152-1.el6.i686
Marking elfutils-libelf-0.152-1.el6.i686.rpm to be installed
Examining elfutils-libelf-0.152-1.el6.x86_64.rpm: elfutils-libelf-0.152-1.el6.x86_64
elfutils-libelf-0.152-1.el6.x86_64.rpm: does not update installed package.
Examining elfutils-libelf-devel-0.152-1.el6.i686.rpm: elfutils-libelf-devel-0.152-1.el6.i686
Marking elfutils-libelf-devel-0.152-1.el6.i686.rpm to be installed
Examining elfutils-libelf-devel-0.152-1.el6.x86_64.rpm: elfutils-libelf-devel-0.152-1.el6.x86_64
elfutils-libelf-devel-0.152-1.el6.x86_64.rpm: does not update installed package.
Examining gcc-4.4.6-3.el6.x86_64.rpm: gcc-4.4.6-3.el6.x86_64
gcc-4.4.6-3.el6.x86_64.rpm: does not update installed package.
Examining gcc-c++-4.4.6-3.el6.x86_64.rpm: gcc-c++-4.4.6-3.el6.x86_64
gcc-c++-4.4.6-3.el6.x86_64.rpm: does not update installed package.
Examining glibc-2.12-1.47.el6.i686.rpm: glibc-2.12-1.47.el6.i686
Marking glibc-2.12-1.47.el6.i686.rpm to be installed
Package glibc-2.12-1.47.el6.i686 already installed and latest version
glibc-2.12-1.47.el6.i686.rpm: does not update installed package.
Examining glibc-2.12-1.47.el6.x86_64.rpm: glibc-2.12-1.47.el6.x86_64
Marking glibc-2.12-1.47.el6.x86_64.rpm to be installed
Package glibc-2.12-1.47.el6.x86_64 already installed and latest version
glibc-2.12-1.47.el6.x86_64.rpm: does not update installed package.
Examining glibc-common-2.12-1.47.el6.x86_64.rpm: glibc-common-2.12-1.47.el6.x86_64
glibc-common-2.12-1.47.el6.x86_64.rpm: does not update installed package.
Examining glibc-devel-2.12-1.47.el6.i686.rpm: glibc-devel-2.12-1.47.el6.i686
Marking glibc-devel-2.12-1.47.el6.i686.rpm to be installed
Examining glibc-devel-2.12-1.47.el6.x86_64.rpm: glibc-devel-2.12-1.47.el6.x86_64
glibc-devel-2.12-1.47.el6.x86_64.rpm: does not update installed package.
Examining glibc-headers-2.12-1.47.el6.x86_64.rpm: glibc-headers-2.12-1.47.el6.x86_64
glibc-headers-2.12-1.47.el6.x86_64.rpm: does not update installed package.
Examining ksh-20100621-12.el6.x86_64.rpm: ksh-20100621-12.el6.x86_64
ksh-20100621-12.el6.x86_64.rpm: does not update installed package.
Examining libaio-0.3.107-10.el6.i686.rpm: libaio-0.3.107-10.el6.i686
Marking libaio-0.3.107-10.el6.i686.rpm to be installed
Package libaio-0.3.107-10.el6.i686 already installed and latest version
libaio-0.3.107-10.el6.i686.rpm: does not update installed package.
Examining libaio-0.3.107-10.el6.x86_64.rpm: libaio-0.3.107-10.el6.x86_64
Marking libaio-0.3.107-10.el6.x86_64.rpm to be installed
Package libaio-0.3.107-10.el6.x86_64 already installed and latest version
libaio-0.3.107-10.el6.x86_64.rpm: does not update installed package.
Examining libaio-devel-0.3.107-10.el6.i686.rpm: libaio-devel-0.3.107-10.el6.i686
Marking libaio-devel-0.3.107-10.el6.i686.rpm to be installed
Package libaio-devel-0.3.107-10.el6.i686 already installed and latest version
libaio-devel-0.3.107-10.el6.i686.rpm: does not update installed package.
Examining libaio-devel-0.3.107-10.el6.x86_64.rpm: libaio-devel-0.3.107-10.el6.x86_64
Marking libaio-devel-0.3.107-10.el6.x86_64.rpm to be installed
Package libaio-devel-0.3.107-10.el6.x86_64 already installed and latest version
libaio-devel-0.3.107-10.el6.x86_64.rpm: does not update installed package.
Examining libgcc-4.4.6-3.el6.i686.rpm: libgcc-4.4.6-3.el6.i686
Marking libgcc-4.4.6-3.el6.i686.rpm to be installed
Package libgcc-4.4.6-3.el6.i686 already installed and latest version
libgcc-4.4.6-3.el6.i686.rpm: does not update installed package.
Examining libgcc-4.4.6-3.el6.x86_64.rpm: libgcc-4.4.6-3.el6.x86_64
Marking libgcc-4.4.6-3.el6.x86_64.rpm to be installed
Package libgcc-4.4.6-3.el6.x86_64 already installed and latest version
libgcc-4.4.6-3.el6.x86_64.rpm: does not update installed package.
Examining libstdc++-4.4.6-3.el6.i686.rpm: libstdc++-4.4.6-3.el6.i686
Marking libstdc++-4.4.6-3.el6.i686.rpm to be installed
Package libstdc++-4.4.6-3.el6.i686 already installed and latest version
libstdc++-4.4.6-3.el6.i686.rpm: does not update installed package.
Examining libstdc++-4.4.6-3.el6.x86_64.rpm: libstdc++-4.4.6-3.el6.x86_64
Marking libstdc++-4.4.6-3.el6.x86_64.rpm to be installed
Package libstdc++-4.4.6-3.el6.x86_64 already installed and latest version
libstdc++-4.4.6-3.el6.x86_64.rpm: does not update installed package.
Examining libstdc++-devel-4.4.6-3.el6.i686.rpm: libstdc++-devel-4.4.6-3.el6.i686
Marking libstdc++-devel-4.4.6-3.el6.i686.rpm to be installed
Package libstdc++-devel-4.4.6-3.el6.i686 already installed and latest version
libstdc++-devel-4.4.6-3.el6.i686.rpm: does not update installed package.
Examining libstdc++-devel-4.4.6-3.el6.x86_64.rpm: libstdc++-devel-4.4.6-3.el6.x86_64
Marking libstdc++-devel-4.4.6-3.el6.x86_64.rpm to be installed
Package libstdc++-devel-4.4.6-3.el6.x86_64 already installed and latest version
libstdc++-devel-4.4.6-3.el6.x86_64.rpm: does not update installed package.
Examining make-3.81-19.el6.x86_64.rpm: 1:make-3.81-19.el6.x86_64
make-3.81-19.el6.x86_64.rpm: does not update installed package.
No package sysstat-7.* available.
Examining unixODBC-2.2.14-11.el6.i686.rpm: unixODBC-2.2.14-11.el6.i686
Marking unixODBC-2.2.14-11.el6.i686.rpm to be installed
Examining unixODBC-2.2.14-11.el6.x86_64.rpm: unixODBC-2.2.14-11.el6.x86_64
unixODBC-2.2.14-11.el6.x86_64.rpm: does not update installed package.
Examining unixODBC-devel-2.2.14-11.el6.i686.rpm: unixODBC-devel-2.2.14-11.el6.i686
Marking unixODBC-devel-2.2.14-11.el6.i686.rpm to be installed
Examining unixODBC-devel-2.2.14-11.el6.x86_64.rpm: unixODBC-devel-2.2.14-11.el6.x86_64
unixODBC-devel-2.2.14-11.el6.x86_64.rpm: does not update installed package.
No package pdksh* available.
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package elfutils-libelf.i686 0:0.152-1.el6 will be installed
---> Package elfutils-libelf-devel.i686 0:0.152-1.el6 will be installed
---> Package glibc-devel.i686 0:2.12-1.47.el6 will be installed
---> Package unixODBC.i686 0:2.2.14-11.el6 will be installed
--> Processing Dependency: libltdl.so.7 for package: unixODBC-2.2.14-11.el6.i686
--> Processing Dependency: libreadline.so.6 for package: unixODBC-2.2.14-11.el6.i686
---> Package unixODBC-devel.i686 0:2.2.14-11.el6 will be installed
--> Running transaction check
---> Package libtool-ltdl.i686 0:2.2.6-15.5.el6 will be installed
---> Package readline.i686 0:6.0-3.el6 will be installed
--> Processing Dependency: libtinfo.so.5 for package: readline-6.0-3.el6.i686
--> Running transaction check
---> Package ncurses-libs.i686 0:5.7-3.20090208.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===========================================================================================================================
 Package                      Arch        Version                     Repository                                      Size
===========================================================================================================================
Installing:
 elfutils-libelf              i686        0.152-1.el6                 /elfutils-libelf-0.152-1.el6.i686              906 k
 elfutils-libelf-devel        i686        0.152-1.el6                 /elfutils-libelf-devel-0.152-1.el6.i686         31 k
 glibc-devel                  i686        2.12-1.47.el6               /glibc-devel-2.12-1.47.el6.i686                953 k
 unixODBC                     i686        2.2.14-11.el6               /unixODBC-2.2.14-11.el6.i686                   1.1 M
 unixODBC-devel               i686        2.2.14-11.el6               /unixODBC-devel-2.2.14-11.el6.i686             182 k
Installing for dependencies:
 libtool-ltdl                 i686        2.2.6-15.5.el6              rhel-source                                     45 k
 ncurses-libs                 i686        5.7-3.20090208.el6          rhel-source                                    251 k
 readline                     i686        6.0-3.el6                   rhel-source                                    176 k

Transaction Summary
===========================================================================================================================
Install       8 Package(s)

Total size: 3.6 M
Total download size: 471 k
Installed size: 4.3 M
Is this ok [y/N]: y
Downloading Packages:
---------------------------------------------------------------------------------------------------------------------------
Total                                                                                      3.1 MB/s | 471 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
  Installing : ncurses-libs-5.7-3.20090208.el6.i686                                                                    1/8 
  Installing : readline-6.0-3.el6.i686                                                                                 2/8 
  Installing : libtool-ltdl-2.2.6-15.5.el6.i686                                                                        3/8 
  Installing : unixODBC-2.2.14-11.el6.i686                                                                             4/8 
  Installing : elfutils-libelf-0.152-1.el6.i686                                                                        5/8 
  Installing : elfutils-libelf-devel-0.152-1.el6.i686                                                                  6/8 
  Installing : unixODBC-devel-2.2.14-11.el6.i686                                                                       7/8 
  Installing : glibc-devel-2.12-1.47.el6.i686                                                                          8/8 
Installed products updated.

Installed:
  elfutils-libelf.i686 0:0.152-1.el6     elfutils-libelf-devel.i686 0:0.152-1.el6     glibc-devel.i686 0:2.12-1.47.el6    
  unixODBC.i686 0:2.2.14-11.el6          unixODBC-devel.i686 0:2.2.14-11.el6         

Dependency Installed:
  libtool-ltdl.i686 0:2.2.6-15.5.el6        ncurses-libs.i686 0:5.7-3.20090208.el6        readline.i686 0:6.0-3.el6       

Complete!
[root@Ptyjkweb Packages]# 

原来是有8个32bit的相关包未安装,装完以后点击retry后,错误解决,继续之后的安装,但是到快要结束的时候,又报
[INS 20802] Oracle Net Configuration Assistant failed”的错误:



继续查看安装日志,发现其中有一个core dumped,后来尝试跳过完成安装,但最后执行tnsping命令的时候,会报core dumped错误

[oracle@Ptyjkweb ~]$ tail 100 /home/oracle/oraInventory/logs/installActions2015-07-09_11-03-57AM.log 
tail: cannot open `100' for reading: No such file or directory
==> /home/oracle/oraInventory/logs/installActions2015-07-09_11-03-57AM.log <==
INFO: #
INFO: # An error report file with more information is saved as hs_err_pid13287.log
INFO: #
INFO: # If you would like to submit a bug report, please visit:
INFO: #   http://java.sun.com/webapps/bugreport/crash.jsp
INFO: #
WARNING: /oracle/client_1/bin/netca: line 178: 13287 Aborted                 (core dumped) $JRE $JRE_OPTIONS -classpath $CLASSPATH oracle.net.ca.NetCA $*
INFO: 
WARNING: 
INFO: Completed Plugin named: Oracle Net Configuration Assistant
[oracle@Ptyjkweb ~]$ 

解决方案是安装Oracle 11.2.0.1.0软件的补丁:p8670579_112010_LINUX.zip(同样适用于db software)
可以去http://down.51cto.com/data/780691下载到该补丁,解压并cd到解压完的目录8670579中,开始安装补丁

[oracle@Ptyjkweb ~]$ unzip p8670579_112010_LINUX.zip
[oracle@Ptyjkweb ~]$ cd 8670579/
[oracle@Ptyjkweb 8670579]$ ls -l
total 16
drwxr-xr-x. 4 oracle oinstall 4096 Jul  9 15:32 etc
drwxr-xr-x. 3 oracle oinstall 4096 Jul  9 15:32 files
-rw-r--r--. 1 oracle oinstall 5163 Jul  9 15:32 README.txt
[oracle@Ptyjkweb 8670579]$ $ORACLE_HOME/OPatch/opatch apply -invPtrLoc $ORACLE_HOME/oraInst.loc
Invoking OPatch 11.1.0.6.6

Oracle Interim Patch Installer version 11.1.0.6.6
Copyright (c) 2009, Oracle Corporation.  All rights reserved.


Oracle Home       : /oracle/client_1
Central Inventory : /home/oracle/oraInventory
   from           : /oracle/client_1/oraInst.loc
OPatch version    : 11.1.0.6.6
OUI version       : 11.2.0.1.0
OUI location      : /oracle/client_1/oui
Log file location : /oracle/client_1/cfgtoollogs/opatch/opatch2015-07-09_15-36-52PM.log

Patch history file: /oracle/client_1/cfgtoollogs/opatch/opatch_history.txt


--------------------------------------------------------------------------------
The patch has more than one Archive Action but there is no Make Action.
--------------------------------------------------------------------------------
ApplySession applying interim patch '8670579' to OH '/oracle/client_1'

Running prerequisite checks...

OPatch detected non-cluster Oracle Home from the inventory and will patch the local system only.


Please shutdown Oracle instances running out of this ORACLE_HOME on the local system.
(Oracle Home = '/oracle/client_1')


Is the local system ready for patching? [y|n]
y    
User Responded with: Y
Backing up files and inventory (not for auto-rollback) for the Oracle Home
Backing up files affected by the patch '8670579' for restore. This might take a while...
Backing up files affected by the patch '8670579' for rollback. This might take a while...

Patching component oracle.network.rsf, 11.2.0.1.0...
Updating archive file "/oracle/client_1/lib/libnnz11.a"  with "lib/libnnz11.a/ahseteco.o"
Updating archive file "/oracle/client_1/lib/libnnz11.a"  with "lib/libnnz11.a/am11rkg.o"
Updating archive file "/oracle/client_1/lib/libnnz11.a"  with "lib/libnnz11.a/amsha.o"
Updating archive file "/oracle/client_1/lib/libnnz11.a"  with "lib/libnnz11.a/cpui32.o"
Updating archive file "/oracle/client_1/lib/libnnz11.a"  with "lib/libnnz11.a/sha.o"
Updating archive file "/oracle/client_1/lib/libnnz11.a"  with "lib/libnnz11.a/x931rand.o"
Updating archive file "/oracle/client_1/lib/libnnz11.a"  with "lib/libnnz11.a/am11dkg.o"
Updating archive file "/oracle/client_1/lib/libnnz11.a"  with "lib/libnnz11.a/am931rnd.o"
Updating archive file "/oracle/client_1/lib/libnnz11.a"  with "lib/libnnz11.a/amsharnd.o"
Updating archive file "/oracle/client_1/lib/libnnz11.a"  with "lib/libnnz11.a/ghash.o"
Updating archive file "/oracle/client_1/lib/libnnz11.a"  with "lib/libnnz11.a/shacomm.o"
Copying file to "/oracle/client_1/lib/libnnz11.so"
ApplySession adding interim patch '8670579' to inventory

Verifying the update...
Inventory check OK: Patch ID 8670579 is registered in Oracle Home inventory with proper meta-data.
Files check OK: Files from Patch ID 8670579 are present in Oracle Home.

The local system has been patched and can be restarted.


OPatch succeeded.
[oracle@Ptyjkweb 8670579]$ 

补丁打好后,点击安装程序的retry,继续安装即可,然后就可以正常使用netca、tnsping、sqlplus等命令了



python-cx_oracle报错"DatabaseError: DPI-1047: 64-bit Oracle Client library cannot be loaded: "

用python跑数据库脚本时,python报错"DatabaseError: DPI-1047: 64-bit Oracle Client library cannot be loaded: " ...
  • yuzh_test
  • yuzh_test
  • 2017年12月26日 00:43
  • 1937

python 连接oracle 报错 cx_Oracle.DatabaseErro

python 连接oracle 报错 cx_Oracle.DatabaseErro
  • joeyon
  • joeyon
  • 2014年08月29日 11:01
  • 3190

Python(Pycharm)连接Oracle数据库之cx_Oracle的使用(cx_Oracle在pyCharm中报错)

首先声明Python27+Windows32安装 我的电脑Windows版本是64位的,但是由于Pycharm中的pycrypto中使用了C语言的代码所以我在装Pycharm的时候装的是32位的,不需...
  • longlongValue
  • longlongValue
  • 2017年04月26日 12:47
  • 4439

python中cx_Oracle模块安装遇到的问题与解决方法

     安装或使用cx_Oracle时,需要用到Oracel的链接库,如libclntsh.so.10.1,否则会有各种各样的错误信息。     安装Oracle Instant Client就可得...
  • huzhenwei
  • huzhenwei
  • 2009年03月01日 00:44
  • 34456

python连接oracle-从编码到版本不兼容等问题

用python连接oracle所遇到的相关问题,从编码到版本不兼容的解决方案
  • FrankLao93
  • FrankLao93
  • 2017年12月08日 23:56
  • 353

Linux下连接oracle,出现cx_Oracle.DatabaseError: DPI-1047: 64-bit Oracle Client library cannot be loaded: “

按照这里的步骤 将 oracle客户端安装到Linux上即可, https://oracle.github.io/odpi/doc/installation.html#linux...
  • Com_ma
  • Com_ma
  • 2017年11月21日 20:01
  • 3717

Python连接Oracle

转自:https://segmentfault.com/a/1190000009878547 当前环境:Linux Centos 7 1. 下载安装包cx_Oracle 由于我本地Python版...
  • saabe
  • saabe
  • 2017年08月24日 15:12
  • 222

win7 64位系统 PB连接oracle数据库出现“oracle library oci.dll could not be loaded”问题的解决方法

 今天与大家分享一个自己的学习笔记,希望能给遇到同样问题的人带来帮助。        不知道大家在win7 64位系统下用 PB连接oracle数据库时,是否遇到过“oracle librar...
  • lijianhe043
  • lijianhe043
  • 2016年11月08日 14:48
  • 7477

解决:Cannot load ocl.dll library(error code 126). The ocil.dll library may be missing from the system

解决:Cannot load ocl.dll library(error code 126). The ocil.dll library may be missing from the system...
  • xb12369
  • xb12369
  • 2014年10月28日 12:51
  • 9927

cx_Oracle 报错:cx_Oracle.DatabaseError: DPI-1050: Oracle Client library must be at version 11.2

解决:从 https://pypi.python.org/pypi/cx_Oracle/5.3 下载低版本cx_Oracle版本 我是下载cx_Oracle-5.3-11g.win32-py3.6....
  • u014770372
  • u014770372
  • 2017年10月26日 17:29
  • 2082
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:安装Oracle 11g client(32bit)错误分析(后续)
举报原因:
原因补充:

(最多只允许输入30个字)