poj2886 Who Gets the Most Candies?

Who Gets the Most Candies?
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 12326 Accepted: 3842
Case Time Limit: 2000MS

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If Ais negative, the next child will be the (A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers  N (0 <  N  ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3

Source




反素数+线段树思路很好

首先可以发现获得糖果最多的小孩的出队顺序tot是小于等于n的最大反素数。(不知道反素数的去百度…)

我选择用筛表法求反素数。(打表更快)

接下来的问题就是模拟tot次出队操作了。这里可以用线段树维护区间内还有多少个孩子没有出队,每次求出下一个孩子是第几个。(具体方法详见代码,自己画个图就理解了…)

这道题用线段树的思路很好,将寻找下一个出队位置的复杂度从O(n)降低到O(logn)。




#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cmath>
#include<cstring>
#define F(i,j,n) for(int i=j;i<=n;i++)
#define D(i,j,n) for(int i=j;i>=n;i--)
#define LL long long
#define pa pair<int,int>
#define MAXN 500005
using namespace std;
int n,k,tot,pos,mod,f[MAXN];
struct kid_type
{
	char s[20];int val;
}a[MAXN];
struct tree_type
{
	int l,r,sum;
}t[MAXN*4];
void build(int k,int x,int y)
{
	t[k].l=x;t[k].r=y;t[k].sum=y-x+1;
	if (x==y) return;
	int mid=(x+y)>>1;
	build(k<<1,x,mid);
	build(k<<1|1,mid+1,y);
}
int update(int k,int x)
{
	t[k].sum--;
	if (t[k].l==t[k].r) return t[k].l;
	if (t[k<<1].sum>=x) return update(k<<1,x);
	else return update(k<<1|1,x-t[k<<1].sum);
}
int findmax()
{
	memset(f,0,sizeof(f));
	F(i,1,n) for(int j=i;j<=n;j+=i) f[j]++;
	int mx=0;
	F(i,1,n) if (f[i]>f[mx]) mx=i;
	return mx;
}
int main()
{
//	freopen("input.in","r",stdin);
	a[0].val=0;
	while (~scanf("%d %d\n",&n,&k))
	{
		build(1,1,n);
		F(i,1,n) scanf("%s %d\n",a[i].s,&a[i].val);
		tot=findmax();
		pos=0;
		mod=n;
		F(i,1,tot)
		{
			if (a[pos].val>0) k=((k+a[pos].val-2)%mod+mod)%mod+1;
			else k=((k+a[pos].val-1)%mod+mod)%mod+1;
			pos=update(1,k);
			mod--;
		}
		printf("%s %d\n",a[pos].s,f[tot]);
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值