SDUT-14级训练1-Crossword Answers

A crossword puzzle consists of a rectangular grid of black and white squares and two lists of definitions (or descriptions).

One list of definitions is for ``words" to be written left to right across white squares in the rows and the other list is for words to be written down white squares in the columns. (A word is a sequence of alphabetic characters.)

To solve a crossword puzzle, one writes the words corresponding to the definitions on the white squares of the grid.

The definitions correspond to the rectangular grid by means of sequential integers on ``eligible" white squares. White squares with black squares immediately to the left or above them are ``eligible." White squares with no squares either immediately to the left or above are also ``eligible." No other squares are numbered. All of the squares on the first row are numbered.

The numbering starts with 1 and continues consecutively across white squares of the first row, then across the eligible white squares of the second row, then across the eligible white squares of the third row and so on across all of the rest of the rows of the puzzle. The picture below illustrates a rectangular crossword puzzle grid with appropriate numbering.

An ``across" word for a definition is written on a sequence of white squares in a row starting on a numbered square that does not follow another white square in the same row.

The sequence of white squares for that word goes across the row of the numbered square, ending immediately before the next black square in the row or in the rightmost square of the row.

A ``down" word for a definition is written on a sequence of white squares in a column starting on a numbered square that does not follow another white square in the same column.

The sequence of white squares for that word goes down the column of the numbered square, ending immediately before the next black square in the column or in the bottom square of the column.

Every white square in a correctly solved puzzle contains a letter.

You must write a program that takes several solved crossword puzzles as input and outputs the lists of across and down words which constitute the solutions.

Input

Each puzzle solution in the input starts with a line containing two integers r and c ( tex2html_wrap_inline39 and tex2html_wrap_inline41 ), where r (the first number) is the number of rows in the puzzle and c (the second number) is the number of columns.

The r rows of input which follow each contain c characters (excluding the end-of-line) which describe the solution. Each of those c characters is an alphabetic character which is part of a word or the character ``*", which indicates a black square.

The end of input is indicated by a line consisting of the single number 0.

Output

Output for each puzzle consists of an identifier for the puzzle (puzzle #1:, puzzle #2:, etc.) and the list of across words followed by the list of down words. Words in each list must be output one-per-line in increasing order of the number of their corresponding definitions.

The heading for the list of across words is ``Across". The heading for the list of down words is ``Down".

In the case where the lists are empty (all squares in the grid are black), the Across and Down headings should still appear.

Separate output for successive input puzzles by a blank line.

Sample Input

2 2
AT
*O
6 7
AIM*DEN
*ME*ONE
UPON*TO
SO*ERIN
*SA*OR*
IES*DEA
0

Sample Output

puzzle #1:
Across
  1.AT
  3.O
Down
  1.A
  2.TO

puzzle #2:
Across
  1.AIM
  4.DEN
  7.ME
  8.ONE
  9.UPON
 11.TO
 12.SO
 13.ERIN
 15.SA
 17.OR
 18.IES
 19.DEA
Down
  1.A
  2.IMPOSE
  3.MEO
  4.DO
  5.ENTIRE
  6.NEON
  9.US
 10.NE
 14.ROD
 16.AS
 18.I

20.A

AC CODE:

#include<stdio.h>
#include<string.h>
int main()
{
    int a[15][15],i,j,k,m,n,t=1,e;
    char b[15][15];
    while(~scanf("%d",&m) && m!=0)
    {
        scanf("%d",&n);
        for(i=0;i<m;i++)
        {
            scanf("%s",b[i]);
        }
        k=1;
        memset(a,0,sizeof(a));
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                if(b[i][j]=='*')
                    continue;
                if(i-1<0 || b[i-1][j]=='*' || j-1<0 || b[i][j-1]=='*')
                    a[i][j]=k++;
            }
        }
        if(t!=1)
            printf("\n");
        printf("puzzle #%d:\n",t++);
        printf("Across\n");
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                if(b[i][j]=='*' || a[i][j]==0)
                    continue;
                printf("%3d.",a[i][j]);
                while(b[i][j]!='*'  && j<n)
                {
                    printf("%c",b[i][j++]);
                }

                printf("\n");
            }
        }
        printf("Down\n");
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                if(b[i][j]=='*' || a[i][j]==0)
                    continue;
                printf("%3d.",a[i][j]);
                e=i;
                while(b[i][j]!='*' && i<m)
                {
                    printf("%c",b[i++][j]);
                    a[i][j]=0;
                }

                printf("\n");
                i=e;
            }
        }
    }
    return 0;
}


不好想到的一点是竖行输出的时候,其次就是思路问题了,找不到编号规律,是个大问题。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值