UVA 714 Copying Books 最大值最小化问题 (贪心 + 二分)

  Copying Books 

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.


Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered $1, 2, \dots, m$) that may have different number of pages ( $p_1, p_2, \dots, p_m$) and you want to make one copy of each of them. Your task is to divide these books among k scribes, $k \le m$. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers$0 = b_0 <b_1 < b_2, \dots < b_{k-1} \le b_k = m$ such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

Input 

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k$1 \le k \le m \le 500$. At the second line, there are integers$p_1, p_2, \dots p_m$ separated by spaces. All these values are positive and less than 10000000.

Output 

For each case, print exactly one line. The line must contain the input succession $p_1, p_2, \dots p_m$ divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character (`/') to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash.


If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

Sample Input 

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100

Sample Output 

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100

题意:给定一个n个数的序列。要求分为m个连续子序列。要求出一种划分方法使得。子序列的和的最大值。是最小的。

思路:LRJ书上的最大值最小化问题。把问题转换为能否把输入序列划分成m个子序列使得所有和不超过x。如果为假。就往上找。如果为真就往下找。一开始可以定下界为序列中最小的数字。上界上序列之和。然后进行二分查找。

过程中判断划分的方法是用了贪心。尽量往右边划分。。

这题在输出的地方折腾了我好一会- - 蛋都碎了。。注意如果剩下的数字已经等于还要插入'/'的数量,那么每个剩下每个数字之间直接全部插入’/‘即可。。

还有个注意点。就是二分的时候要记得用longlong。。。

代码:

#include <stdio.h>
#include <string.h>

int t;
int n, m;
long long start, end;
int num[505];
int out[505];
int outn;
int judge(int x) {//判断能否把输入序列划分成m个连续子序列。。
    int sb = n - 1;
    for (int i = 0; i < m; i ++) {
	long long sum = 0;
	while (sum + num[sb] <= x) {
	    sum += num[sb];
	    if (sb == 0)
		return 1;
	    sb --;
	}
    }
    return 0;
}
int main() {
    scanf("%d", &t);
    while (t --) {
	start = 10000000;
	outn = 0;
	memset(out, 0, sizeof(out));
	scanf("%d%d", &n, &m);
	for (int i = 0; i < n; i ++) {
	    scanf("%d", &num[i]);
	    end += num[i];
	    if (start > num[i])
		start = num[i];
	}
	long long sb;//记得long long不然会悲剧。。
	while (start < end) {//二分查找
	    sb = (start + end) / 2;
	    if (judge(sb)) {
		if (end == sb) 
		    break; 
		end = sb;
	    }
	    else {
		if (start == sb)
		    break;
		start = sb;
	    }
	}
	if (!judge(sb))
	    sb ++;
	int i = n - 1;
	while (i != -1){//用一个out来判断输出'/'的位置。。
	    long long sum = 0;
	    while (sum + num[i] <= sb) {
		sum += num[i --];
		if (i == -1)
		    break;
	    }
	    if (i != -1) {
		out[i] = 1;
		outn ++;
	    }
	}
	if (outn != m - 1) {//如果'/'不足。在前面几个数之间补满'/'
	    for (int i = 0; i < n; i ++) {
		if (!out[i]) {
		    out[i] = 1;
		    outn ++;
		    if (outn == m - 1)
			break;
		}
	    }
	}
	for (int i = 0; i < n - 1; i ++) {
	    printf("%d ", num[i]);
	    if (out[i]) printf("/ ");
	}
	printf("%d\n", num[n - 1]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值