ZOJ Problem Set - 1698 Easier Done Than Said?

Easier Done Than Said?

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.


Input

The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.


Output

For each password, output whether or not it is acceptable, using the precise format shown in the example.


Sample Input

a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end


Sample Output

<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.


Source: Mid-Central USA 2000   





分析:

题意:

给一个密码(全部是小写字母,长度在20个字符以内),要求判断该密码是否可接受。一个密码可接受必须同时满足以下三个条件:

(1)字符串至少包含一个元音字母(a,e,i,o,u)。

(2)字符串中不包含三个连续的元音或三个连续的辅音。

(3)不能包含两个相同的连续字母,但ee和oo除外。




简单题。直接判断是否同时符合这三个条件就行。因为只有20个字符,用char[]处理就足够了。

注意:

c语言一行写不下该怎么换行

   
参考答案

  用连接符 \

  比如

  char a[]={A,B,A,B,A,B,A,B,A,B,A,B,A,B, \

  C}





ac代码:

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char c[22];
int main()
{
    int i,j;
    while(scanf("%s",c)&&strcmp(c,"end")!=0)
    {
        bool flag=0;
        int L=strlen(c);
        for(i=0;i<L;i++)
        {
            if(c[i]=='a'||c[i]=='e'||c[i]=='i'||c[i]=='o'||c[i]=='u')
            flag=1;
            if(i>1)
            {
                if(((c[i]=='a'||c[i]=='e'||c[i]=='i'||c[i]=='o'||c[i]=='u')\
                    &&(c[i-1]=='a'||c[i-1]=='e'||c[i-1]=='i'||c[i-1]=='o'||c[i-1]=='u')\
                    &&(c[i-2]=='a'||c[i-2]=='e'||c[i-2]=='i'||c[i-2]=='o'||c[i-2]=='u'))\
                   ||((c[i]!='a'&&c[i]!='e'&&c[i]!='i'&&c[i]!='o'&&c[i]!='u')\
                     &&(c[i-1]!='a'&&c[i-1]!='e'&&c[i-1]!='i'&&c[i-1]!='o'&&c[i-1]!='u')\
                      &&(c[i-2]!='a'&&c[i-2]!='e'&&c[i-2]!='i'&&c[i-2]!='o'&&c[i-2]!='u')))
                      break;
            }
            if(i>0)
            {
                if(c[i]==c[i-1]&&(c[i]!='e'&&c[i]!='o'))
                {
                   // printf("%d ",i);
                    break;
                }


            }
        }
        printf("<%s> is ",c);
        if(flag&&i==L)
        printf("acceptable.\n");
        else
        printf("not acceptable.\n");
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值