hdu 3524 Perfect Squares(找规律,循环节,快速幂取模)

Perfect Squares

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 546    Accepted Submission(s): 293


Problem Description
A number x is called a perfect square if there exists an integer b 
satisfying x=b^2. There are many beautiful theorems about perfect squares in mathematics. Among which, Pythagoras Theorem is the most famous. It says that if the length of three sides of a right triangle is a, b and c respectively(a < b <c), then a^2 + b^2=c^2. 
In this problem, we also propose an interesting question about perfect squares. For a given n, we want you to calculate the number of different perfect squares mod 2^n. We call such number f(n) for brevity. For example, when n=2, the sequence of {i^2 mod 2^n} is 0, 1, 0, 1, 0……, so f(2)=2. Since f(n) may be quite large, you only need to output f(n) mod 10007.
 

Input
The first line contains a number T<=200, which indicates the number of test case.
Then it follows T lines, each line is a positive number n(0<n<2*10^9).
 

Output
For each test case, output one line containing "Case #x: y", where x is the case number (starting from 1) and y is f(x).
 

Sample Input
  
  
2 1 2
 

Sample Output
  
  
Case #1: 2 Case #2: 2
题意:任何数模上2^n都会有循环节,给你n问你循环节里有多少个不同的数字。

思路:不知如何入手,先打个表再说。前15项是

2 2 3 4 7 12 23 44 87 172 343 684 1367 2732 5463

可以发现规律: 

奇数项:2 3 7 23 87 343 1367 5463

偶数项:2 4 12 44 172 684 2732

奇数项分别相差1,4,16,64,256,1024

偶数项相差2,8,32,128,512,2048

所以奇数项f[n]=f[n-1]+2^(2*n-4),偶数项f[n]=f[n-1]+2^(2*n-3)

所以可以求得通项公式

奇数项f[n]=(2^(2*n-2)+5)/3

偶数项f[n]=(2^(2*n-1)+4)/3

所以对于一个给定的数即可直接代入公式求解了。注意此处除以3不能直接取模会出错。我们可以对3*mod取模,然后最后再除以3.

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define LL long long
#define mod 30021
LL pow_mod(LL a,LL n)
{
    LL ans=1;
    while(n)
    {
        if(n&1) ans=ans*a%mod;
        a=a*a%mod;
        n>>=1;
    }
    return ans;
}
int main()
{
    int T;
    LL n,ans;
    scanf("%d",&T);
    for(int t=1;t<=T;t++)
    {
        scanf("%lld",&n);
        if(n&1) ans=((pow_mod(2,2*(n/2+1)-2)+5)%mod)/3;
        else ans=(pow_mod(2,2*(n/2)-1)+4)%mod/3;
        printf("Case #%d: %lld\n",t,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值