hdu 1395 2^x mod n = 1(欧拉函数)

2^x mod n = 1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16236    Accepted Submission(s): 5053


Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.
 

Input
One positive integer on each line, the value of n.
 

Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.
 

Sample Input
  
  
2 5
 

Sample Output
  
  
2^? mod 2 = 1 2^4 mod 5 = 1

题意:求一个最小的正整数x让2^x mod n = 1.

思路:如果gcd(2,n)!=-1或者n==1的时候显然无解

否则可以用欧拉函数解

欧拉定理:

设gcd(a,m)=1,必有正整数x,使得a^x=1(mod m),且设满足等式的最小正整数为x0,必满足x0|phi(m).注意m>1.

否则如果gcd(a,m)!=1,则方程a^x=1(mod m)没有解。

具体实现可以看代码了

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define LL long long
LL e[1000008],t;
LL pow_mod(LL a,LL n,LL mod)
{
    LL ans=1;
    while(n)
    {
        if(n&1) ans=ans*a%mod;
        a=a*a%mod;
        n>>=1;
    }
    return ans;
}
LL gcd(LL a,LL b)
{
    return b?gcd(b,a%b):a;
}
LL euler_phi(LL n)//欧拉函数
{
    LL m=sqrt(n+0.5);
    LL ans=n,i;
    for(i=2; i<=m; i++)
    {
        if(n%i==0)
        {
            ans=ans/i*(i-1);
            while(n%i==0)n=n/i;
        }
    }
    if(n>1)ans=ans/n*(n-1);
    return ans;
}
void finds(LL n)
{
    LL i;
    e[t++]=n;

    for(i=2; i*i<=n; i++)
    {
        if(n%i==0)
        {
            if(i*i==n)
                e[t++]=i;
            else
            {
                e[t++]=i;
                e[t++]=n/i;
            }
        }
    }
}
int main()
{
    int T;
    LL a,n;
    while(~scanf("%lld",&n))
    {
        if(n%2==0||n==1)
        {
            printf("2^? mod %lld = 1\n",n);
            continue;
        }
        LL m=euler_phi(n);
        t=0;
        finds(m);
        sort(e,e+t);
        LL ans;
        for(int i=0; i<t; i++)
        {
            if(pow_mod(2,e[i],n)==1)
            {
                ans=e[i];
                break;
            }
        }
        printf("2^%lld mod %lld = 1\n",ans,n);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值