hdu1532 Drainage Ditches (网络流入门)

题目大意:

其实就是最大流裸题。

求点1-m的最大流量。

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15011    Accepted Submission(s): 7129


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
 

Sample Input
  
  
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
  
  
50

思路:

直接上模板就好了。


代码如下:

#include <map>
#include <set>
#include <cmath>
#include <queue>
#include <vector>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long LL;
const int maxn=1e6+10;
const int INF=0x3f3f3f3f;
int cas=1,T;
struct node
{
	int to,cap,rev;
	node(){}
	node(int a,int b,int c):to(a),cap(b),rev(c){}
};
vector<node>mp[maxn];
bool vis[maxn];
void addedge(int start,int to,int cap)
{
	mp[start].push_back(node(to,cap,mp[to].size()));
	mp[to].push_back(node(start,0,mp[start].size()-1));
}

int DFS(int start,int end,int cap)
{
	if(start==end)return cap;
	vis[start]=true;
	int size=mp[start].size();
	for(int i=0;i<size;i++)
	{
		node& temp=mp[start][i];
		if(temp.cap<=0||vis[temp.to])continue;
		int d=DFS(temp.to,end,min(cap,temp.cap));
		if(d)
		{
			temp.cap-=d;
			mp[temp.to][temp.rev].cap+=d;
			return d;
		}
	}
	return 0;
}
int maxflow(int start,int end)
{
	int flow=0;
	int f=INF;
	while(f)
	{
		memset(vis,false,sizeof(vis));
		f=DFS(start,end,INF);
		flow+=f;
	}
	return flow;
}
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)==2)
	{
		int u,v,w;
		for(int i=0;i<n;i++)mp[i].clear();
		while(n--)
		{
			scanf("%d%d%d",&u,&v,&w);
			addedge(u,v,w);
		}
		int ans=maxflow(1,m);
		printf("%d\n",ans);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值