数据结构实验之查找三:树的种类统计

数据结构实验之查找三:树的种类统计

Time Limit: 400MS Memory limit: 65536K

题目描述

随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。

输入

输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。

输出

按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。

示例输入

2
This is an Appletree
this is an appletree

示例输出

this is an appletree 100.00%

提示

 

来源

xam 

示例程序

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct node
{
    int num;
    char data[100];
    struct node *lchild,*rchild;
}tree;
int n;
void creat(tree *&root,char str[])
{
    if(root == NULL)
    {
        root = (tree *)malloc(sizeof(tree));
        strcpy(root->data,str);
        root->num = 1;
        root->lchild = root->rchild = NULL;
    }
    else
    {
        if(strcmp(root->data,str) > 0)
             creat(root->lchild,str);
        else if(strcmp(root->data,str) < 0)
             creat(root->rchild,str);
        else
             root->num++;
    }

}
void ldr(tree *root)
{
    if(root == NULL)
        return ;
    else
    {
        ldr(root->lchild);
        printf("%s %.2lf%c\n",root->data,root->num*100.0/n,'%');
        ldr(root->rchild);
    }
}
int main()
{
    char str[100];
    tree *root;
    root = NULL;
    scanf("%d\n",&n);                           //这里有一点需要注意,在输入完n一定要加一个换行字符。
    for(int j = 0;j < n;j++)
    {
        gets(str);
        for(int i = 0;i < str[i];i++)
        {
            if(str[i] >= 'A' && str[i] <= 'Z')
            {
                str[i] = str[i] + 32;
            }
        }
        creat(root,str);
    }
    ldr(root);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值