HDU1072-Nightmare【广度优先搜索】

Nightmare
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7069    Accepted Submission(s): 3397


Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

 

Sample Input
3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4
1 0 0 0 1 0 0 1
1 4 1 0 1 1 0 1
1 0 0 0 0 3 0 1
1 1 4 1 1 1 1 1
 

Sample Output
4
-1
13
 

Author
Ignatius.L
 

 

 


//广度优先遍历......
具体参看http://blog.csdn.net/acmman/article/details/38342115
(第一次写广搜,代码参考了HDU的讨论区)

#include<cstdio>
#include<iostream>
#include<queue>
#define N 10
using namespace std;
int map[N][N],n,m;
int dir[4][2]=
{
    {0,1},  /*向右*/
    {0,-1}, /*向左*/
 {-1,0},  /*向下*/
 {1,0}  /*向上*/
};
struct Node
{
   int x,y;//记录坐标 
   int step,time;//步数和时间 
}start;
void BFS()
{
   queue<Node>q;//队列实现
   Node q1,q2;//交换值,相当于temp 
   q.push(start);//将start放入队列
   
   //队列为空时说明 1.已经扫描到结果
   //2.完全扫描结束(没找到结果)
   while(!q.empty())
   {
      int i;
      q1=q.front();//将队头的数据拿出来
      q.pop();//将队头弹出
      //开始搜索上下左右四个方向 
      for(i=0;i<4;i++)
      {
         q2.x=q1.x+dir[i][0];
         q2.y=q1.y+dir[i][1];
         q2.step=q1.step+1;
         q2.time=q1.time-1;
         //判断走这一步是否已经超出矩阵范围 
          //确定此步不是走过的(或墙)或者炸弹时间已到 
         if(q2.x>=0&&q2.y>=0&&q2.x<n&&q2.y<m&&map[q2.x][q2.y]!=0&&q2.time>0)
         {
            //说明找到答案,结束搜索 
            if(map[q2.x][q2.y]==3)
            {
               printf("%d\n",q2.step);
               return;                    
            }
            else if(map[q2.x][q2.y]==4)
            {//碰到时间调整器,可以恢复时间 
                 q2.time=6;
                 map[q2.x][q2.y]=0; //标记已经走过   
            }  
            q.push(q2);//将这一步放进队列                               
         }
      } 
   }  
   //队列扫完都没搜到答案,说明答案不存在
   printf("-1\n");
   return;
}
int main()
{
    int i,j,T;
    scanf("%d",&T);
    while(T--)
    {
       scanf("%d %d",&n,&m);
       for(i=0;i<n;i++)
         for(j=0;j<m;j++)
         {
            scanf("%d",&map[i][j]);
            if(map[i][j]==2)
            {
               start.x=i;
               start.y=j;
               start.step=0;
               start.time=6;//时间初始化为6 
            }
         }
         BFS(); 
    }
    return 0;
}
  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

光仔December

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值