Hdu 2795-Billboard【线段树 优化】



Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13874    Accepted Submission(s): 5955


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
题意清晰,给的时间虽然很长,但是题目给的数据超级大,朴素的算法根本不要想,就连朴素的线段树都不行,__Xiong交了好几次全是TLE,大家要对线段树遍历的时候进行再优化,具体我已在代码注释 微笑 题意 :h*w 的木板 , 放进一些 1*L 的物品 , 求每次放空间能容纳且最上边的位子 思路 : 每次找到最大值的位子 , 然后减去 L
#include <cstdio>
#include <string>
#include <sstream>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
const int maxn = 200000+5;
int H,W,N,width,row;
int segTree[maxn<<2];   //segTree存每一层当前的最大剩余width
void PushUp(int rt) { segTree[rt] = max(segTree[rt<<1],segTree[rt<<1|1]); }
void Build(int l,int r,int rt) {
    segTree[rt] = W;
    if(l == r) {
        return ;
    }
    int mid = l+((r-l)>>1);
    Build(lson);
    Build(rson);
}
//返回 >= wid 最小的行数,顺便一边更新 将Update和Query操作合并了
int Solve(const int& wid,int l,int r,int rt) {
    int ret,mid;
    if(l == r) {
        segTree[rt] -= wid; return l;
    }
    mid = l+((r-l)>>1);
    ret = segTree[rt<<1]>=wid?Solve(wid,lson):Solve(wid,rson);//先看向下看看左结点保留的最大值,小了就往右儿子遍历
    PushUp(rt);
    return ret;
}
int main() {
   // freopen("input.in","r",stdin);
    int ans;
    while(~scanf("%d %d %d",&H,&W,&N)) {
        if(H > N) H = N; // H最大也就 N这样,应该很好理解
        Build(1,H,1);
        for(int i = 1;i <= N;i++) {
            scanf("%d",&width);
            if(width > W) { printf("-1\n");continue; }
            if(segTree[1] < width) { printf("-1\n");continue; }//segTree[1]为根节点,保留1~H之间的最大值
            ans = Solve(width,1,H,1);
            printf("%d\n",ans);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值