仓库管理声明// 随机获取神器子程序,用于密码箱和武器合成

原创 2012年03月21日 10:03:34

 

//首先把芯片的主副不要设为0!!! 还

// 分解后取出背包武器子程序


分解后取出背包武器子程序
参数 英文名串
参数 主副串
参数 小类型串
局部变量
英文名串数组
配置文件名
i 整数型
j 整数型
k 整数型
数组长度
txtTemp

deagle ak47   knife
  2      1      3

英文名串数组 = 分割文本(英文名串,"&")
数组长度 = 取数组成员数(英文名串数组)

 


.计次循环首(数组长度,i)
 配置文件名=配置文件名库.取自定义背包配置文件名()
 .计次循环首(3,j)
  txtTemp=读配置项(配置文件名,"list"+到文本(j),"item"+到文本(主副串[i])
  .如果真(txtTemp=英文名串数组[i])
   写配置项(配置文件名,"list"+到文本(j),"item"+到文本(主副串[i]),"blank")
  .如果真结束
 .计次循环尾
 配置文件名=配置文件名库.取快速购买编辑配置文件名()
 .计次循环首(5,j)
  txtTemp=读配置项(配置文件名,"list"+到文本(j),"item"+到文本(主副串[i])
  .如果真(txtTemp=英文名串数组[i])
   写配置项(配置文件名,"list"+到文本(j),"item"+到文本(主副串[i]),"blank")
   显示快速购买编辑 j
   显示快速购买编辑单个 j
  .如果真结束
 .计次循环尾
 配置文件名=配置文件名库.取编辑购买菜单配置文件名()
 .计次循环首(9,j)
  txtTemp=读配置项(配置文件名,"list"+到文本(小类型串[i]),"item"+到文本(j)
  .如果真(txtTemp=英文名串数组[i])
   写配置项(配置文件名,"list"+到文本(小类型串[i]),"item"+到文本(j),"blank")
   显示编辑购买菜单子程序()
  .如果真结束
 .计次循环尾
.计次循环尾


// 使用按钮被放开

 i 整数型

 主副=仓库当前选中的枪支.取主副()
 英文名 = 仓库当前选中的枪支.取英文名()
 .如果真(仓库当前选中的枪支.取大种类()=1 或 仓库当前选中的枪支.取大种类()=3)
  装备到背包子程序()
 .如果真结束
  .如果真(仓库当前选中的枪支.取大种类()=2)
  信息框("功能未完善")
 .如果真结束
 .如果真(仓库当前选中的枪支.取大种类()=4)
  .如果真(主副=1)'喷涂
   txtTemp=读配置项(配置文件名库.取道具配置文件名(),"detail","currentSpray")
   .如果真(英文名!=txtTemp)
    .计次循环首(仓库列表长度数组[10],i)
     .如果真(仓库当前道具列表[i]=txtTemp)
      仓库动画框.置图片(仓库枪支使用期限_标识[i],nousing)
      跳出循环()
     .如果真结束
    .计次循环尾
    仓库动画框.置图片(仓库枪支使用期限_标识[i],using)
    复制文件(仓库当前选中的枪支.取英文名() 到cstrikechinese)
    
   .如果真结束
   要显示的消息["changeSpray"]
   
  .如果真结束
   
  .如果真(主副=2 且 仓库所在位置=1)'纹身
   txtTemp=读配置项(配置文件名库.取道具配置文件名(),"detail","currentTaboo")
   .如果真(英文名!=txtTemp)
    .计次循环首(仓库列表长度数组[10],i)
     .如果真(仓库当前道具列表[i]=txtTemp)
      仓库动画框.置图片(仓库枪支使用期限_标识[i],nousing)
      跳出循环()
     .如果真结束
    .计次循环尾
    仓库动画框.置图片(仓库枪支使用期限_标识[i],using)
    仓库动画框.置图片(仓库使用的纹身图片_标识,仓库当前选中的枪支.取枪支图片(1))
    复制文件(英文名相关文件夹 到cstrikechinese)
    
   .如果真结束
   要显示的消息[1]="changeTaboo"
   载入(弹出_消息)
   
  .如果真结束
  .如果真(主副=5 或 6)'设计图或各种材料
   要显示的消息[1]="gotoFactory"
   载入(弹出_消息)
  .如果真结束
  .如果真(英文名=passwordBox 或 英文名=key)'密码箱或card
   要显示的消息[1]="gotoPasswordBox"
   载入(弹出_消息)
  .如果真结束

  .如果真(英文名=)'金币兑换券,确认使用?
   要显示的消息[1]="confirmUse"
   置随机种子()
   i=取随机数(1,4)
   要显示的消息[2]=到文本(4000*i)
   载入(弹出_获得道具)
  .如果真结束
 .如果真结束

 

 

// 生成武器包子程序
程序集变量:

英文名
中文名
简介

大种类
小种类
主副

伤害
连射
准确度
重量
后坐力

配置文件名
设计图数组

p模型路径
v模型路径
w模型路径

枪支图片路径
枪支特殊功能图路径
枪支中文名图片路径
枪支登录器简介图片路径
枪支tga图片路径
枪支中文名tga图片路径

射击音效
其它音效 数组


生成武器包子程序()

英文名=英文名.内容
中文名=中文名.内容
简介=简介.内容

大种类=大种类.内容
小种类=小种类.内容
主副=主副.内容

伤害=伤害.内容
连射=连射.内容
准确度=准确度.内容
重量=重量.内容
后坐力=后坐力.内容

设计图数组={,,,,,,,,}


配置文件名=取运行目录()+"\gun\Program\config\detail.ini"

写配置项(配置文件名,"detail","ename",英文名)
写配置项(配置文件名,"detail","cname",英文名)
写配置项(配置文件名,"detail","damage",英文名)
写配置项(配置文件名,"detail","ename",英文名)
写配置项(配置文件名,"detail","ename",英文名)
写配置项(配置文件名,"detail","ename",英文名)
写配置项(配置文件名,"detail","ename",英文名)

 

 

 

c++ 子程序声明

#include "stdafx.h" #include using namespace std; void print(); int main() { print(); return 0; ...
  • osummertime
  • osummertime
  • 2016年07月26日 13:24
  • 934

oracle 的错误整理

PACKAGE BODY HII.HTP_SCHOOLWARM 编译错误错误:PLS-00323: 子程序或游标 ‘F_GET_WARNINGNM’ 已在程序包说明中声明, 必须在程序包体中对其进行定...
  • fugushiba
  • fugushiba
  • 2017年04月17日 17:36
  • 214

子程序定义-3

递归调用: 子程序可以互相调用,当调用该子程序本身时,即成了递归子程序。 递归子程序有两个条件: 1.除了不被子程序改变的变量外,所有的变量必须是局部的 2.该子程序要含有停止调用本身的代码。...
  • zhaoyangjian724
  • zhaoyangjian724
  • 2014年11月13日 16:09
  • 305

代码大全(3)之子程序

子程序在结构设计中应该被指出: 子程序将要包含的信息 子程序的输入 子程序的输出,包括受到影响的全局变量 子程序将如何处理错误 创建子程序: 是否检查过先决条件已经满足了吗 定义子程...
  • woshibendangao
  • woshibendangao
  • 2017年03月14日 08:52
  • 295

子程序定义-1

子程序即一段分离的代码,它可以使减少重复代码且使程序易读。PERL中,子程序可以出现在程序的任何地方。 但一般放在程序的开始或结尾。 sub subroute{ statements: } S...
  • zhaoyangjian724
  • zhaoyangjian724
  • 2014年11月13日 16:08
  • 431

GPU:合成加速

公司内部同事翻译的一篇技术文章,很多干货,讲解了浏览器渲染的一些原理的东西,值得一读。...
  • fendouzhe123
  • fendouzhe123
  • 2015年10月14日 16:58
  • 1092

移动密码箱

手机上的密码管理程序。索爱大部分机型都可以跑,其它品牌的没试过,对于国产的除联想、多普达之外就一定不用试了。图文介绍如下:第一次登录进行数据库初始化 主界面与编辑对话框 节点移动与锁定功能 短消息支持...
  • cq_bmy
  • cq_bmy
  • 2007年10月22日 09:30
  • 1930

程序中断和调用子程序有何区别

两者的根本区别表现在服务时间和服务对象上不一样。 1)调用子程序发生的时间是已知的和固定的,即在主程序的调用指令(CALL)执行时发生主程序调用子程序过程,调用指令所在位置是已知的和固定的;而中断过程...
  • jxq0816
  • jxq0816
  • 2015年12月01日 00:57
  • 7183

子程序(过程、函数、方法)

一般程序设计语言包含两种基本的抽象:过程抽象和数据抽象。过程抽象有时也称控制抽象。   子程序在1950年以前就发明了,作为一种抽象那时候并未被完全接受。相反,最初它被看做是一种节省代码的...
  • bytxl
  • bytxl
  • 2015年09月08日 09:12
  • 1306

JavaScript实现的简单的点名代码

随机点名 var arr = new Array("小王","小二","小张","小六","小松"); var r = Math.round(Math.random()*(...
  • LGJ1025
  • LGJ1025
  • 2012年11月24日 14:37
  • 916
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:仓库管理声明// 随机获取神器子程序,用于密码箱和武器合成
举报原因:
原因补充:

(最多只允许输入30个字)