关闭

仓库管理声明// 随机获取神器子程序,用于密码箱和武器合成

335人阅读 评论(0) 收藏 举报

 

//首先把芯片的主副不要设为0!!! 还

// 分解后取出背包武器子程序


分解后取出背包武器子程序
参数 英文名串
参数 主副串
参数 小类型串
局部变量
英文名串数组
配置文件名
i 整数型
j 整数型
k 整数型
数组长度
txtTemp

deagle ak47   knife
  2      1      3

英文名串数组 = 分割文本(英文名串,"&")
数组长度 = 取数组成员数(英文名串数组)

 


.计次循环首(数组长度,i)
 配置文件名=配置文件名库.取自定义背包配置文件名()
 .计次循环首(3,j)
  txtTemp=读配置项(配置文件名,"list"+到文本(j),"item"+到文本(主副串[i])
  .如果真(txtTemp=英文名串数组[i])
   写配置项(配置文件名,"list"+到文本(j),"item"+到文本(主副串[i]),"blank")
  .如果真结束
 .计次循环尾
 配置文件名=配置文件名库.取快速购买编辑配置文件名()
 .计次循环首(5,j)
  txtTemp=读配置项(配置文件名,"list"+到文本(j),"item"+到文本(主副串[i])
  .如果真(txtTemp=英文名串数组[i])
   写配置项(配置文件名,"list"+到文本(j),"item"+到文本(主副串[i]),"blank")
   显示快速购买编辑 j
   显示快速购买编辑单个 j
  .如果真结束
 .计次循环尾
 配置文件名=配置文件名库.取编辑购买菜单配置文件名()
 .计次循环首(9,j)
  txtTemp=读配置项(配置文件名,"list"+到文本(小类型串[i]),"item"+到文本(j)
  .如果真(txtTemp=英文名串数组[i])
   写配置项(配置文件名,"list"+到文本(小类型串[i]),"item"+到文本(j),"blank")
   显示编辑购买菜单子程序()
  .如果真结束
 .计次循环尾
.计次循环尾


// 使用按钮被放开

 i 整数型

 主副=仓库当前选中的枪支.取主副()
 英文名 = 仓库当前选中的枪支.取英文名()
 .如果真(仓库当前选中的枪支.取大种类()=1 或 仓库当前选中的枪支.取大种类()=3)
  装备到背包子程序()
 .如果真结束
  .如果真(仓库当前选中的枪支.取大种类()=2)
  信息框("功能未完善")
 .如果真结束
 .如果真(仓库当前选中的枪支.取大种类()=4)
  .如果真(主副=1)'喷涂
   txtTemp=读配置项(配置文件名库.取道具配置文件名(),"detail","currentSpray")
   .如果真(英文名!=txtTemp)
    .计次循环首(仓库列表长度数组[10],i)
     .如果真(仓库当前道具列表[i]=txtTemp)
      仓库动画框.置图片(仓库枪支使用期限_标识[i],nousing)
      跳出循环()
     .如果真结束
    .计次循环尾
    仓库动画框.置图片(仓库枪支使用期限_标识[i],using)
    复制文件(仓库当前选中的枪支.取英文名() 到cstrikechinese)
    
   .如果真结束
   要显示的消息["changeSpray"]
   
  .如果真结束
   
  .如果真(主副=2 且 仓库所在位置=1)'纹身
   txtTemp=读配置项(配置文件名库.取道具配置文件名(),"detail","currentTaboo")
   .如果真(英文名!=txtTemp)
    .计次循环首(仓库列表长度数组[10],i)
     .如果真(仓库当前道具列表[i]=txtTemp)
      仓库动画框.置图片(仓库枪支使用期限_标识[i],nousing)
      跳出循环()
     .如果真结束
    .计次循环尾
    仓库动画框.置图片(仓库枪支使用期限_标识[i],using)
    仓库动画框.置图片(仓库使用的纹身图片_标识,仓库当前选中的枪支.取枪支图片(1))
    复制文件(英文名相关文件夹 到cstrikechinese)
    
   .如果真结束
   要显示的消息[1]="changeTaboo"
   载入(弹出_消息)
   
  .如果真结束
  .如果真(主副=5 或 6)'设计图或各种材料
   要显示的消息[1]="gotoFactory"
   载入(弹出_消息)
  .如果真结束
  .如果真(英文名=passwordBox 或 英文名=key)'密码箱或card
   要显示的消息[1]="gotoPasswordBox"
   载入(弹出_消息)
  .如果真结束

  .如果真(英文名=)'金币兑换券,确认使用?
   要显示的消息[1]="confirmUse"
   置随机种子()
   i=取随机数(1,4)
   要显示的消息[2]=到文本(4000*i)
   载入(弹出_获得道具)
  .如果真结束
 .如果真结束

 

 

// 生成武器包子程序
程序集变量:

英文名
中文名
简介

大种类
小种类
主副

伤害
连射
准确度
重量
后坐力

配置文件名
设计图数组

p模型路径
v模型路径
w模型路径

枪支图片路径
枪支特殊功能图路径
枪支中文名图片路径
枪支登录器简介图片路径
枪支tga图片路径
枪支中文名tga图片路径

射击音效
其它音效 数组


生成武器包子程序()

英文名=英文名.内容
中文名=中文名.内容
简介=简介.内容

大种类=大种类.内容
小种类=小种类.内容
主副=主副.内容

伤害=伤害.内容
连射=连射.内容
准确度=准确度.内容
重量=重量.内容
后坐力=后坐力.内容

设计图数组={,,,,,,,,}


配置文件名=取运行目录()+"\gun\Program\config\detail.ini"

写配置项(配置文件名,"detail","ename",英文名)
写配置项(配置文件名,"detail","cname",英文名)
写配置项(配置文件名,"detail","damage",英文名)
写配置项(配置文件名,"detail","ename",英文名)
写配置项(配置文件名,"detail","ename",英文名)
写配置项(配置文件名,"detail","ename",英文名)
写配置项(配置文件名,"detail","ename",英文名)

 

 

 

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:1937次
    • 积分:42
    • 等级:
    • 排名:千里之外
    • 原创:3篇
    • 转载:0篇
    • 译文:0篇
    • 评论:1条
    文章存档
    最新评论