仓库管理声明// 随机获取神器子程序,用于密码箱和武器合成

原创 2012年03月21日 10:03:34

 

//首先把芯片的主副不要设为0!!! 还

// 分解后取出背包武器子程序


分解后取出背包武器子程序
参数 英文名串
参数 主副串
参数 小类型串
局部变量
英文名串数组
配置文件名
i 整数型
j 整数型
k 整数型
数组长度
txtTemp

deagle ak47   knife
  2      1      3

英文名串数组 = 分割文本(英文名串,"&")
数组长度 = 取数组成员数(英文名串数组)

 


.计次循环首(数组长度,i)
 配置文件名=配置文件名库.取自定义背包配置文件名()
 .计次循环首(3,j)
  txtTemp=读配置项(配置文件名,"list"+到文本(j),"item"+到文本(主副串[i])
  .如果真(txtTemp=英文名串数组[i])
   写配置项(配置文件名,"list"+到文本(j),"item"+到文本(主副串[i]),"blank")
  .如果真结束
 .计次循环尾
 配置文件名=配置文件名库.取快速购买编辑配置文件名()
 .计次循环首(5,j)
  txtTemp=读配置项(配置文件名,"list"+到文本(j),"item"+到文本(主副串[i])
  .如果真(txtTemp=英文名串数组[i])
   写配置项(配置文件名,"list"+到文本(j),"item"+到文本(主副串[i]),"blank")
   显示快速购买编辑 j
   显示快速购买编辑单个 j
  .如果真结束
 .计次循环尾
 配置文件名=配置文件名库.取编辑购买菜单配置文件名()
 .计次循环首(9,j)
  txtTemp=读配置项(配置文件名,"list"+到文本(小类型串[i]),"item"+到文本(j)
  .如果真(txtTemp=英文名串数组[i])
   写配置项(配置文件名,"list"+到文本(小类型串[i]),"item"+到文本(j),"blank")
   显示编辑购买菜单子程序()
  .如果真结束
 .计次循环尾
.计次循环尾


// 使用按钮被放开

 i 整数型

 主副=仓库当前选中的枪支.取主副()
 英文名 = 仓库当前选中的枪支.取英文名()
 .如果真(仓库当前选中的枪支.取大种类()=1 或 仓库当前选中的枪支.取大种类()=3)
  装备到背包子程序()
 .如果真结束
  .如果真(仓库当前选中的枪支.取大种类()=2)
  信息框("功能未完善")
 .如果真结束
 .如果真(仓库当前选中的枪支.取大种类()=4)
  .如果真(主副=1)'喷涂
   txtTemp=读配置项(配置文件名库.取道具配置文件名(),"detail","currentSpray")
   .如果真(英文名!=txtTemp)
    .计次循环首(仓库列表长度数组[10],i)
     .如果真(仓库当前道具列表[i]=txtTemp)
      仓库动画框.置图片(仓库枪支使用期限_标识[i],nousing)
      跳出循环()
     .如果真结束
    .计次循环尾
    仓库动画框.置图片(仓库枪支使用期限_标识[i],using)
    复制文件(仓库当前选中的枪支.取英文名() 到cstrikechinese)
    
   .如果真结束
   要显示的消息["changeSpray"]
   
  .如果真结束
   
  .如果真(主副=2 且 仓库所在位置=1)'纹身
   txtTemp=读配置项(配置文件名库.取道具配置文件名(),"detail","currentTaboo")
   .如果真(英文名!=txtTemp)
    .计次循环首(仓库列表长度数组[10],i)
     .如果真(仓库当前道具列表[i]=txtTemp)
      仓库动画框.置图片(仓库枪支使用期限_标识[i],nousing)
      跳出循环()
     .如果真结束
    .计次循环尾
    仓库动画框.置图片(仓库枪支使用期限_标识[i],using)
    仓库动画框.置图片(仓库使用的纹身图片_标识,仓库当前选中的枪支.取枪支图片(1))
    复制文件(英文名相关文件夹 到cstrikechinese)
    
   .如果真结束
   要显示的消息[1]="changeTaboo"
   载入(弹出_消息)
   
  .如果真结束
  .如果真(主副=5 或 6)'设计图或各种材料
   要显示的消息[1]="gotoFactory"
   载入(弹出_消息)
  .如果真结束
  .如果真(英文名=passwordBox 或 英文名=key)'密码箱或card
   要显示的消息[1]="gotoPasswordBox"
   载入(弹出_消息)
  .如果真结束

  .如果真(英文名=)'金币兑换券,确认使用?
   要显示的消息[1]="confirmUse"
   置随机种子()
   i=取随机数(1,4)
   要显示的消息[2]=到文本(4000*i)
   载入(弹出_获得道具)
  .如果真结束
 .如果真结束

 

 

// 生成武器包子程序
程序集变量:

英文名
中文名
简介

大种类
小种类
主副

伤害
连射
准确度
重量
后坐力

配置文件名
设计图数组

p模型路径
v模型路径
w模型路径

枪支图片路径
枪支特殊功能图路径
枪支中文名图片路径
枪支登录器简介图片路径
枪支tga图片路径
枪支中文名tga图片路径

射击音效
其它音效 数组


生成武器包子程序()

英文名=英文名.内容
中文名=中文名.内容
简介=简介.内容

大种类=大种类.内容
小种类=小种类.内容
主副=主副.内容

伤害=伤害.内容
连射=连射.内容
准确度=准确度.内容
重量=重量.内容
后坐力=后坐力.内容

设计图数组={,,,,,,,,}


配置文件名=取运行目录()+"\gun\Program\config\detail.ini"

写配置项(配置文件名,"detail","ename",英文名)
写配置项(配置文件名,"detail","cname",英文名)
写配置项(配置文件名,"detail","damage",英文名)
写配置项(配置文件名,"detail","ename",英文名)
写配置项(配置文件名,"detail","ename",英文名)
写配置项(配置文件名,"detail","ename",英文名)
写配置项(配置文件名,"detail","ename",英文名)

 

 

 

maven入门浅析(三)-----maven仓库管理器Nexus的安装配置详细步骤

简述:        Nexus 是Maven仓库管理器,如果你使用Maven,你可以从Maven中央仓库 下载所需要的构件(artifact),但这通常不是一个好的做法,你应该在本地架设一个...

一起学Maven(Maven仓库管理器之初识Nexus)<五>

认识Nexus Nexus是Maven的最常用的仓库管理器,可以认为是Maven的私服,通过此可以免去自己(本地仓库)直接去购买游戏提供商的服务(Maven的中央仓库),减少费用开支(带宽和...

CentOS/Ubuntu安装nexus(Maven仓库管理器)

Nexus是一个强大的Maven仓库管理器, 它极大地简化了自己内部仓库的维护和外部仓库的访问。 利用Nexus你可以只在一个地方就能够完全控制访问和部署在你所维护仓库中的每个Artifact。 Ne...

ubuntu14.04安装maven仓库管理器nexus

1.准备工作    由于nexus依赖jdk,所以需要先安装jdk。这里jdk选择jdk8,安装过程可查看博客:ubuntu14.04安装jdk1.8    nexus源码安装包: nexus-2...
  • qinhGG
  • qinhGG
  • 2017年06月21日 17:49
  • 297

一起学Maven(Maven仓库管理器之应用Nexus)<六>

hosted,本地仓库,这个仓库主要是用来存放本地的依赖包,服务于局域网,不访问公网 proxy,代理仓库,用来存放nexus从公网中获取的依赖包,这里有中央仓库,Apache和Codehaus开源网...

使用仓库管理器——Sonatype Nexus的九大理由 转自:http://juvenshun.iteye.com/blog/285059

目前有很多组织使用了一些工具依赖于Maven仓库,但他们并没有采用一个仓库管理器,对于这一点我十分惊讶。可能没人提出来这一点,没人站出来告诉别人使用一个仓库管理器能带来什么好处。我经常能从很多不使用M...

maven仓库管理器Nexus

访问http://nexus.sonatype.org/downloads/下载Nexus。    启动Nexus,就是启动一个web服务器,它的默认地址是localhost:8081。Nexu...

Maven仓库管理器Nexus的安装配置

Maven仓库管理器Nexus的安装配置

Maven仓库管理器Nexus的安装配置

Nexus 是Maven仓库管理器,如果你使用Maven,你可以从Maven中央仓库 下载所需要的构件(artifact),但这通常不是一个好的做法,你应该在本地架设一个Maven仓库服务器,在代理远...

WEBX3学习-用Nexus配置Maven仓库管理器

由于webx3采用maven管理项目部署,而maven会用到中央仓库,由于全球都在用中央仓库,下载的速度可想而知,我用的时候简直有点崩溃,所以需要先配置一个中央仓库的代理服务,供局域网内的项目组用,那...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:仓库管理声明// 随机获取神器子程序,用于密码箱和武器合成
举报原因:
原因补充:

(最多只允许输入30个字)