POJ-1862--贪心---Stripies

Akatsuki

Description
Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn’t equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.
Input
The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.
Output
The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.
Sample Input
3
72
30
50
Sample Output
120.000

题意:给一个整数,现在有N个物体,每个物体的质量是m,每两个物体碰撞之后会产生一个新的质量为 2*sqrt(m1*m2)的物体,现在让每两个物体互相碰撞,直到最后剩下一个物体,求这个物体的最大质量。

思路:简单贪心,按照质量从大到小排序,然后利用公式求解即可。

#include<iostream>
#include<queue>
#include<cmath>
#include<iomanip>
using namespace std;
int main()
{
    int n;
    cin>>n;
    int i;
    priority_queue<int,vector<int>,less<int> >q;
    int x;
    for(i=0; i<=n-1; i++)
    {
        cin>>x;
        q.push(x);
    }
    double sum=0;
    sum=q.top();
    q.pop();
    while(!q.empty())
    {
        sum=2.0*sqrt(sum*q.top());
        q.pop();
    }
    cout<<fixed<<setprecision(3)<<sum<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值